If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

libical failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js

RESOLVED FIXED in 5.4

Status

Calendar
Alarms
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: MakeMyDay, Assigned: Decathlon)

Tracking

({intermittent-failure})

Trunk
intermittent-failure

Details

Attachments

(1 attachment, 1 obsolete attachment)

2.36 KB, patch
Fallen
: review+
Details | Diff | Splinter Review
(Reporter)

Description

2 years ago
This seems to be a similar as bug 1244818 but for libical. Also, it seems only to happen in the first hours of the first day in a month. The test fails at a different iteration of the test steps than the icaljs test in bug 1244818.

See https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=5d5f6a1ada2667aaeba53d8ded15e3de6bcd6095

19:14:49     INFO -  Retrying tests that failed when run in parallel.
19:14:49     INFO -  TEST-START | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js
19:14:51  WARNING -  TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | xpcshell return code: 0
19:14:51     INFO -  TEST-INFO took 2282ms
19:14:51     INFO -  >>>>>>>
19:14:51     INFO -  PROCESS | 7108 | LoadingC:\\slave\\test\\build\\application\\thunderbird\\extensions\\{e2fda1a4-762b-4020-b5ad-a41df1933103}\\chrome.manifest
19:14:51     INFO -  PROCESS | 7108 | [calBackendLoader] Using libical backend at C:\\slave\\test\\build\\application\\thunderbird\\extensions\\{e2fda1a4-762b-4020-b5ad-a41df1933103}\\components\\libical-manifest
19:14:51     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
19:14:51     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
19:14:51     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
19:14:51     INFO -  running event loop
19:14:51     INFO -  xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | Starting
19:14:51     INFO -  (xpcshell/head.js) | test pending (2)
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js |  - true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js |  - true == true
19:14:51     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
19:14:51     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: assignment to undeclared variable ICAL" {file: "resource://calendar/modules/ical.js" line: 44}]"
19:14:51     INFO -  (xpcshell/head.js) | test run_next_test 1 pending (2)
19:14:51     INFO -  (xpcshell/head.js) | test finished (2)
19:14:51     INFO -  xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | Starting test_addItems
19:14:51     INFO -  (xpcshell/head.js) | test test_addItems pending (2)
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 97] true == true
19:14:51     INFO -  (xpcshell/head.js) | test run_next_test 1 finished (2)
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 101] true == true
19:14:51     INFO -  PROCESS | 7108 | Warning: Warning:  Using guessed timezone
19:14:51     INFO -  PROCESS | 7108 |   America/Los_Angeles (UTC-0800/-0700).
19:14:51     INFO -  PROCESS | 7108 | This ZoneInfo timezone seems to match the operating system timezone this year.
19:14:51     INFO -  PROCESS | 7108 | This ZoneInfo timezone was chosen based on the operating system timezone
19:14:51     INFO -  PROCESS | 7108 | identifier "Pacific Standard Time".
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51     INFO -  TEST-PASS | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] true == true
19:14:51  WARNING -  TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] false == true
19:14:51     INFO -  C:/slave/test/build/tests/xpcshell/tests/calendar/test/unit/test_alarmservice.js:do_check_xor:12
19:14:51     INFO -  C:/slave/test/build/tests/xpcshell/tests/calendar/test/unit/test_alarmservice.js:obs_checkExpected:82
19:14:51     INFO -  C:/slave/test/build/tests/xpcshell/tests/calendar/test/unit/test_alarmservice.js:test_addItems/<:354
19:14:51     INFO -  C:/slave/test/build/tests/xpcshell/tests/calendar/test/unit/test_alarmservice.js:doRunTest/<:338
19:14:51     INFO -  C:/slave/test/build/tests/xpcshell/tests/calendar/test/unit/test_alarmservice.js:obs_onAlarmsLoaded:36
19:14:51     INFO -  resource://calendar/modules/calUtils.jsm -> file:///C:/slave/test/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:notifyFunc:1218
19:14:51     INFO -  resource://calendar/modules/calUtils.jsm -> file:///C:/slave/test/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:calListenerBag_notify:1224
19:14:51     INFO -  resource://calendar/modules/calUtils.jsm -> file:///C:/slave/test/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calAlarmService.js:cAS_findAlarms/cAS_fA_onOperationComplete/<:501
19:14:51     INFO -  C:\slave\test\build\tests\xpcshell\head.js:_do_main:209
19:14:51     INFO -  C:\slave\test\build\tests\xpcshell\head.js:_execute_test:533
19:14:51     INFO -  -e:null:1
19:14:51     INFO -  exiting test
19:14:51     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "Warning:  Using guessed timezone
19:14:51     INFO -    America/Los_Angeles (UTC-0800/-0700).
19:14:51     INFO -  This ZoneInfo timezone seems to match the operating system timezone this year.
19:14:51     INFO -  This ZoneInfo timezone was chosen based on the operating system timezone
19:14:51     INFO -  identifier "Pacific Standard Time"." {file: "file:///C:/slave/test/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calTimezoneService.js" line: 808}]"
19:14:51     INFO -  "CONSOLE_MESSAGE: (error) [JavaScript Error: "2147500036
19:14:51     INFO -  STACK: null" {file: "resource://calendar/modules/calUtils.jsm -> file:///C:/slave/test/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js" line: 1221}]
19:14:51     INFO -  notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///C:/slave/test/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1221:17
19:14:51     INFO -  calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///C:/slave/test/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1224:9
19:14:51     INFO -  cAS_findAlarms/cAS_fA_onOperationComplete/<@resource://calendar/modules/calUtils.jsm -> file:///C:/slave/test/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calAlarmService.js:501:21
19:14:51     INFO -  _do_main@C:\\slave\\test\\build\\tests\\xpcshell\\head.js:209:5
19:14:51     INFO -  _execute_test@C:\\slave\\test\\build\\tests\\xpcshell\\head.js:533:5
19:14:51     INFO -  @-e:1:1
19:14:51     INFO -  "
19:14:51     INFO -  <<<<<<<
(Reporter)

Updated

2 years ago
Component: Internal Components → Alarms

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1103187

Comment 2

2 years ago
oops, libical not ical.js here.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

2 years ago
Summary: libical failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js → libical failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js

Comment 3

a year ago
This just popped up again. Are you sure it doesn't affect users?

Comment 4

a year ago
I think I am seeing this.
I think I am seeing this today.

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&selectedJob=22089
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | xpcshell return code: 0
1239148 Permanent debug test_alarmservice.js | xpcshell return code: 1 | application crashed [@ js::TypeFailure(JSContext *,char const *,...)]
1261688 libical failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js
    1244818 Icaljs failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js

TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] false == true
1239148 Permanent debug test_alarmservice.js | xpcshell return code: 1 | application crashed [@ js::TypeFailure(JSContext *,char const *,...)]
1261688 libical failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js
    1244818 Icaljs failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js

TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | xpcshell return code: 0

1239148 Permanent debug test_alarmservice.js | xpcshell return code: 1 | application crashed [@ js::TypeFailure(JSContext *,char const *,...)]
1261688 libical failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js

    1244818 Icaljs failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js

TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] false == true

1239148 Permanent debug test_alarmservice.js | xpcshell return code: 1 | application crashed [@ js::TypeFailure(JSContext *,char const *,...)]
1261688 libical failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-libical.ini:calendar/test/unit/test_alarmservice.js
1244818 Icaljs failure on first day of the month | TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js
(Assignee)

Comment 5

a year ago
Created attachment 8800209 [details] [diff] [review]
patch-v1

After a few fix in icaljs and libical this bug now occurs for both libraries and in the same way because there is an issue in the test. I think that now bug 1244818 can be marked as duplicated of this one (or vice versa).

In the test there is a monthly recurring event which starts 2 months and one day before the current date. When the current date is the first day of a month, the event starts the last day of a month and if it's the 31st, the next occurrences skip months that have only 30 days hence the map of the "fired" alarm must be adapted.

I've tested the patch for the first day of every month.
I've also added a message for the test "test_addItems" in order to figure out where is the issue when something goes wrong.
Assignee: nobody → bv1578
Status: REOPENED → ASSIGNED
Attachment #8800209 - Flags: review?(philipp)
(Assignee)

Comment 6

a year ago
There's a wrong message in the patch header. I will fix it after the review.
(Assignee)

Comment 7

a year ago
Created attachment 8801852 [details] [diff] [review]
patch - v2

This patch overlaps the test with the patch for bug 1300493 so I've removed the part with the messages for identify single which I will add in bug 1300493.
Attachment #8800209 - Attachment is obsolete: true
Attachment #8800209 - Flags: review?(philipp)
Attachment #8801852 - Flags: review?(philipp)
(Assignee)

Comment 8

a year ago
(In reply to Decathlon from comment #7)
> ...for identify single which I will add in bug 1300493.
  
  ...for identify single TEST which I will add in bug 1300493.
Attachment #8801852 - Flags: review?(philipp) → review+
(Assignee)

Comment 9

a year ago
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/2fb088a124a5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → FIXED
Target Milestone: --- → 5.4
You need to log in before you can comment on or make changes to this bug.