Closed Bug 12620 Opened 21 years ago Closed 21 years ago

M9 crashes when entering a ftp:-URL

Categories

(Core :: Networking, defect, P3, major)

Sun
Solaris
defect

Tracking

()

VERIFIED DUPLICATE of bug 10737

People

(Reporter: roland.mainz, Assigned: gagan)

References

()

Details

My Solaris 7 sparc M9 build crashes when I attempt to open a ftp:-URL

GDB makde the following stack trace:
-- snip --
(gdb) bt
#0  nsFTPChannel::Init (this=0x3416e8, verb=0x171b8 "load", uri=0x3416a0,
aGroup=0x4259b8, getter=0xc1d3b0)
    at ../../../../../netwerk/protocol/ftp/src/nsFTPChannel.cpp:120
#1  0xfc276b64 in nsFtpProtocolHandler::NewChannel (this=0x0, verb=0x171b8
"load", url=0x3416a0, aGroup=0x4259b8,
    eventSinkGetter=0xc1d3b0, result=0xffbec65c) at
../../../../../netwerk/protocol/ftp/src/nsFtpProtocolHandler.cpp:140
#2  0xfd796e74 in nsIOService::NewChannelFromURI (this=0x83780, verb=0x171b8
"load", aURI=0x3416a0, aGroup=0x4259b8,
    eventSinkGetter=0xc1d3b0, result=0xffbec754) at
../../../../netwerk/base/src/nsIOService.cpp:228
#3  0x15014 in NS_OpenURI (result=0xffbec818, uri=0x3416a0, aGroup=0x4259b8,
eventSinkGetter=0xc1d3b0)
    at ../../../../netwerk/util/src/nsNeckoUtil.cpp:63
#4  0xff250a04 in nsDocumentBindInfo::Bind (this=0xe7fa70, aURL=0x3416a0,
aListener=0xc1d3b0, postDataStream=0x0)
    at ../../../webshell/src/nsDocLoader.cpp:1814
#5  0xff2504f0 in nsDocumentBindInfo::Bind (this=0xe7fa70, aURLSpec=@0xffbecc58,
aPostDataStream=0x0, aListener=0x0)
    at ../../../webshell/src/nsDocLoader.cpp:1739
#6  0xff24f0a4 in nsDocLoaderImpl::LoadDocument (this=0x2421c8,
aURLSpec=@0xffbecc58, aCommand=0xffbec97c "",
    aContainer=0x42599c, aPostDataStream=0x0, aExtraInfo=0x0,
anObserver=0x2421c8, aType=0, aLocalIP=0)
    at ../../../webshell/src/nsDocLoader.cpp:726
#7  0xff256b88 in nsWebShell::DoLoadURL (this=0x425c18, aUrlSpec=@0xffbecc58,
aCommand=0xff25bf08 "view",
    aPostDataStream=0x0, aType=0, aLocalIP=0) at
../../../webshell/src/nsWebShell.cpp:2130
#8  0xff257408 in nsWebShell::LoadURL (this=0x425c18, aURLSpec=0x522048,
aCommand=0xff25bf08 "view",
    aPostDataStream=0x0, aModifyHistory=1, aType=0, aLocalIP=0) at
../../../webshell/src/nsWebShell.cpp:2315
#9  0xff255fb4 in nsWebShell::LoadURL (this=0x425c18, aURLSpec=0x522048,
aPostDataStream=0x0, aModifyHistory=1,
    aType=0, aLocalIP=0) at ../../../webshell/src/nsWebShell.cpp:1914
#10 0xfcfb3300 in nsBrowserAppCore::LoadUrl (this=0x515810, aUrl=@0x720038)
    at ../../../../xpfe/AppCores/src/nsBrowserAppCore.cpp:994
#11 0xfcfbc344 in BrowserAppCoreLoadUrl (cx=0x209b70, obj=0xffbecf00, argc=1,
argv=0xaff648, rval=0xffbecfdc)
    at ../../../../xpfe/AppCores/src/nsJSBrowserAppCore.cpp:370
#12 0xfefb26a4 in js_Invoke (cx=0x209b70, argc=1, flags=0) at
../../../js/src/jsinterp.c:654
#13 0xfefb8f3c in js_Interpret (cx=0x209b70, result=0xffbed22c) at
../../../js/src/jsinterp.c:2228
#14 0xfefb26f8 in js_Invoke (cx=0x209b70, argc=0, flags=0) at
../../../js/src/jsinterp.c:670
#15 0xfefb8f3c in js_Interpret (cx=0x209b70, result=0xffbed49c) at
../../../js/src/jsinterp.c:2228
#16 0xfefb26f8 in js_Invoke (cx=0x209b70, argc=1, flags=2) at
../../../js/src/jsinterp.c:670
#17 0xfefb2934 in js_InternalCall (cx=0x209b70, obj=0x2158c8, fval=2185432,
argc=1, argv=0xffbed6fc, rval=0xffbed6f8)
    at ../../../js/src/jsinterp.c:747
#18 0xfef98a10 in JS_CallFunctionValue (cx=0x209b70, obj=0x2158c8, fval=2185432,
argc=1, argv=0xffbed6fc,
    rval=0xffbed6f8) at ../../../js/src/jsapi.c:2643
#19 0xff0da550 in nsJSEventListener::HandleEvent (this=0x3b6bc8,
aEvent=0x74afc0)
    at ../../../../dom/src/events/nsJSEventListener.cpp:97
#20 0xfd259cbc in nsEventListenerManager::HandleEvent (this=0x3baa60,
aPresContext=@0x74afc0, aEvent=0xffbede70,
    aDOMEvent=0xffbed89c, aFlags=3, aEventStatus=@0xffbedca0)
    at ../../../../layout/events/src/nsEventListenerManager.cpp:793
#21 0xfd407cc0 in nsGenericElement::HandleDOMEvent (this=0x3ba49c,
aPresContext=@0x2097b8, aEvent=0xffbede70,
    aDOMEvent=0xffbed89c, aFlags=1, aEventStatus=@0xffbedca0) at
../../../../layout/base/src/nsGenericElement.cpp:779
#22 0xfd2d64a4 in nsHTMLInputElement::HandleDOMEvent (this=0x3ba480,
aPresContext=@0x2097b8, aEvent=0xffbede70,
    aDOMEvent=0x0, aFlags=1, aEventStatus=@0xffbedca0)
    at ../../../../../layout/html/content/src/nsHTMLInputElement.cpp:508
#23 0xfd2974d8 in PresShell::HandleEvent (this=0x221be8, aView=0x3ff050,
aEvent=0xffbede70, aEventStatus=@0xffbedca0)
    at ../../../../../layout/html/base/src/nsPresShell.cpp:1858
#24 0xfce1a304 in nsView::HandleEvent (this=0x3ff050, event=0xffbede70,
aEventFlags=8, aStatus=@0xffbedca0,
    aHandled=@0xffbedb94) at ../../../view/src/nsView.cpp:834
#25 0xfce1a26c in nsView::HandleEvent (this=0x1a9c08, event=0xffbede70,
aEventFlags=28, aStatus=@0xffbedca0,
    aHandled=@0xffbedb94) at ../../../view/src/nsView.cpp:818
#26 0xfce23bb0 in nsViewManager::DispatchEvent (this=0x1a9b80,
aEvent=0xffbede70, aStatus=@0xffbedca0)
    at ../../../view/src/nsViewManager.cpp:1609
#27 0xfce1889c in HandleEvent (aEvent=0xffbede70) at
../../../view/src/nsView.cpp:66
#28 0xff351ebc in nsWidget::DispatchEvent (this=0x3ff0b8, event=0xffbede70,
aStatus=@0xffbedd8c)
---Type <return> to continue, or q <return> to quit---
    at ../../../../widget/src/gtk/nsWidget.cpp:1186
#29 0xff351c5c in nsWidget::DispatchWindowEvent (this=0x3ff0b8,
event=0xffbede70)
    at ../../../../widget/src/gtk/nsWidget.cpp:1050
#30 0xff355ac8 in nsWindow::OnKey (this=0x3ff0b8, aEvent=@0xffbede70) at
../../../../widget/src/gtk/nsWindow.cpp:580
#31 0xff3466f8 in handle_key_release_event (w=0x3fffe8, event=0x1d5ed0,
p=0x3ff0b8)
    at ../../../../widget/src/gtk/nsGtkEventHandler.cpp:589
#32 0xfed59750 in gtk_marshal_BOOL__POINTER (object=0x3fffe8,
    func=0xff346698 <handle_key_release_event(_GtkWidget *, _GdkEventKey *, void
*)>, func_data=0x3ff0b8,
    args=0xffbee0b0) at gtkmarshal.c:30
#33 0xfed072a0 in gtk_handlers_run (handlers=0xc8cd0, signal=0xffbee010,
object=0x3fffe8, params=0xffbee0b0, after=0)
    at gtksignal.c:1909
#34 0xfed061c0 in gtk_signal_real_emit (object=0x3fffe8, signal_id=27,
params=0xffbee0b0) at gtksignal.c:1469
#35 0xfed033d0 in gtk_signal_emit (object=0x3fffe8, signal_id=27) at
gtksignal.c:552
#36 0xfed4bac0 in gtk_widget_event (widget=0x3fffe8, event=0x1d5ed0) at
gtkwidget.c:2790
#37 0xfed5752c in gtk_window_key_release_event (widget=0xf4510, event=0x1d5ed0)
at gtkwindow.c:1131
#38 0xfed59750 in gtk_marshal_BOOL__POINTER (object=0xf4510, func=0xfed573a4
<gtk_window_key_release_event>,
    func_data=0x0, args=0xffbee638) at gtkmarshal.c:30
#39 0xfed06208 in gtk_signal_real_emit (object=0xf4510, signal_id=27,
params=0xffbee638) at gtksignal.c:1484
#40 0xfed033d0 in gtk_signal_emit (object=0xf4510, signal_id=27) at
gtksignal.c:552
#41 0xfed4bac0 in gtk_widget_event (widget=0xf4510, event=0x1d5ed0) at
gtkwidget.c:2790
#42 0xfecc77c4 in gtk_propagate_event (widget=0x3fffe8, event=0x1d5ed0) at
gtkmain.c:1281
#43 0xfecc6770 in gtk_main_do_event (event=0x1d5ed0) at gtkmain.c:753
#44 0xfebcd5dc in gdk_event_dispatch (source_data=0x1d5ed0,
current_time=0xffbeec20, user_data=0x0) at gdkevents.c:2098
#45 0xfeb57138 in g_main_dispatch (current_time=0xffbeec20) at gmain.c:652
#46 0xfeb57a24 in g_main_iterate (block=1228, dispatch=1) at gmain.c:870
#47 0xfeb57c34 in g_main_run (loop=0xea310) at gmain.c:928
#48 0xfecc5fbc in gtk_main () at gtkmain.c:475
#49 0xff3415e0 in nsAppShell::Run (this=0xa5d68) at
../../../../widget/src/gtk/nsAppShell.cpp:371
#50 0xfe57a064 in nsAppShellService::Run (this=0x83d20) at
../../../../xpfe/appshell/src/nsAppShellService.cpp:470
#51 0x141b4 in main1 (argc=0, argv=0xffbef0b4) at
../../../xpfe/bootstrap/nsAppRunner.cpp:761
#52 0x14384 in main (argc=1, argv=0xffbef0b4) at
../../../xpfe/bootstrap/nsAppRunner.cpp:828
-- snip --
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
ftp is not fully implemented yet, bug 10737. Obviously, we shouldn't crash,
however. I will add this info to the other bug report.

*** This bug has been marked as a duplicate of 10737 ***
Status: RESOLVED → VERIFIED
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.