Closed Bug 10737 Opened 21 years ago Closed 20 years ago

[DOGFOOD] sched - get ftp download going (judson, 2d)

Categories

(Core :: Networking, defect, P1)

x86
Windows 95
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: chofmann, Assigned: law)

References

Details

(Whiteboard: [PDT+] 11/19 completion)

Blocks: 10730
Summary: sched - get ftp download going (judson, 2d) → sched - get ftp download going (judson, 2d)
*** Bug 10991 has been marked as a duplicate of this bug. ***
*** Bug 5854 has been marked as a duplicate of this bug. ***
Target Milestone: M9
This is needed for m9.
*** Bug 11122 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Target Milestone: M9 → M10
We can currently download files via ftp from anonymous servers. However, we
aren't displaying directory listings until the appropriate hookup occurs in the
parser. rickg has most, if not all, of this work done, but I won't be able to
get ahold of him until Monday 7/16/99 when he returns to hook it up. Holes still
include authenticaion, and dir display. I'm moving this to M10 as to stop
holding up M9. Progress is steady and problems are understood.
*** Bug 12620 has been marked as a duplicate of this bug. ***
M9 is crashing on ftp URL's on Linux, FWIW (bug 12620)
Mac M9 crashes while trying to follow ftp url on www.gnu.org/software/libc/
libc.html

Link that crashes is the one that says `2.1.1'.
*** Bug 12717 has been marked as a duplicate of this bug. ***
Blocks: 12834
Depends on: 12904
To save time, let me propose the following.  Instead of using the nsIPrompt
interface when you implement this authentication, use the single-signon
interface instead.  It's the same API (same name, almost the same parameters)
and puts up the same prompt dialog.  Only difference is that it gives single
signon a chance to autofill and capture the password.  It will take you the same
amount of time to hook up either interface and it will save me the time of later
converting over what you have done.

Same applies to http authentication which is covered by bug 6144.  I have made
the same comment in that bug report.
Blocks: 7530
Target Milestone: M10 → M13
Whiteboard: waiting on save as dialog stuff from bill law.
Blocks: 14740
jud,
should this bug go over to law?
is the rest of ftp working?
the tree view is cool!

I step down through

ftp://sweetlou/products
  client
  seamonkey
  ...
   ...
    ...

when I get down to the file name level the names of file are cut out
so its a lot of guess work about which file to pick..

I click on the file and got a save dialog.
the dialog doesn't use the file name as default.

if I type in the file name then hit return
it appears that file is being downloaded but then I see a flash of
what might be an error and can find the downloaded file.

Short after that I crashed with this stack

Incident ID 14141420
nsStr::Truncate [d:\builds\seamonkey\mozilla\xpcom\ds\nsStr.cpp, line 306]
nsCString::Assign [d:\builds\seamonkey\mozilla\xpcom\ds\nsString.cpp, line 760]
nsCAutoString::operator=
nsFtpConnectionThread::Process
[d:\builds\seamonkey\mozilla\netwerk\protocol\ftp\src\nsFtpConnectionThread.cpp,
line 263]
nsFtpConnectionThread::Run
[d:\builds\seamonkey\mozilla\netwerk\protocol\ftp\src\nsFtpConnectionThread.cpp,
line 1835]

We most likely need separate bugs for all these problems, but is
this an roughly accruate picture of current state of ftp?
jud,
should this bug go over to law?
is the rest of ftp working?
Assignee: valeski → law
Status: ASSIGNED → NEW
reassigning to law. The crash you describe is likely mine, but law and I have
discussed this download stuff and he's working on the download
unknown-content-type dialog.

Bill, if you'll recall, we need a way to transfer stream control so we don't
download twice.
Whiteboard: waiting on save as dialog stuff from bill law. → [PDT+]waiting on save as dialog stuff from bill law.
Putting on PDT+ radar.
Status: NEW → ASSIGNED
I need to overhaul the guts of the file download dialog to deal with Necko vs.
the old netlib.  This is approaching the top of my list of priorities.
Blocks: 16950
Blocks: 17432
Blocks: 17907
*** Bug 17554 has been marked as a duplicate of this bug. ***
tever to qa contact :-)
QA Contact: paulmac → tever
*** Bug 18016 has been marked as a duplicate of this bug. ***
Bill, why is this M13?
This should be M12 please.
Target Milestone: M13 → M12
Yep, and I was just moving back there. :-)
Blocks: 18471
Priority: P3 → P1
Whiteboard: [PDT+]waiting on save as dialog stuff from bill law. → [PDT+] 11/26??? completion
Whiteboard: [PDT+] 11/26??? completion → [PDT+] 11/19 completion
Enough of this will be done by 11/19 to qualify for dogfood.  Until Necko and
Webshell changes the world.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
OK, we got this working and checked in last week.  I'm going to attempt to close
this bug as fixed.

Most of the bugs that were made duplicates of this one were actually more
generic ftp issues (not "ftp download" per se).  But, those problems should have
been fixed some time ago.

There are still miscellaneous cosmetic issues with "ftp download" (e.g., the
buttons are ugly).  Those either are addressed by existing bugs or should be
addressed with new, specific bugs (please).  There is also some work that will
be done on the implementation to resolve some remaining difficulties.  Those
problems are covered by existing bugs, also.
Status: RESOLVED → VERIFIED
Tested good on 1999112313 build.  Closing this out.
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
No longer blocks: 17432
No longer blocks: 17907
No longer blocks: 18471
You need to log in before you can comment on or make changes to this bug.