Vimeo video using Flash player does not start on Windows XP when clicking "Play" button (low end machine w/o SSE2)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: cirdeiliviu, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(firefox48 affected, firefox49 affected, firefox-esr45 affected, firefox50 affected, firefox51 affected)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
[Affected versions]:
 - Nightly 48.0a1 Build ID 	20160405030214

[Affected OS]
 - Windows XP x32

[Prerequisites]:
 - Have installed Adobe Flash Player v. 21.0.0.197 (https://get.adobe.com/flashplayer/)

[Steps to reproduce]:
1. Open Firefox and go to "https://vimeo.com/".
2. Click on a video. (e.g. "https://vimeo.com/channels/staffpicks/158647901")
3. Press the play button to start the video.

[Expected Results]: The video starts playing.

[Actual Results]: The video shows a black screen even if the buffering bar shows the video is loading until complete. The video starts only after a click is made on "Pause" button then on "Play" button. 

The browser console shows the following errors:
 - "Media resource mediasource:https://vimeo.com/17f0a567-0f78-4bbe-91a1-e29596b54487 could not be decoded."

 - "Media resource https://fpdl.vimeocdn.com/vimeo-prod-skyfire-std-us/01/1729/6/158647901/495872194.mp4?token=5704cbf3_0xcc33c50a996f0a5062b1e8522ea2df19204b3081 could not be decoded."

[Notes]:  
 1. Works on Firefox 45.0.1 on the same machine.
 2. I tried to use mozregression to find a regression range but all builds worked well. 

[Machine info]: 
 - Intel Pentium 4 CPU 3.00GHz 3.00GHz, 3.11 GB of RAM
 - Windows Windows XP Professional Version 2002 Service Pack 3

[Graphics]: 
Adapter Description	Intel(R) 82945G Express Chipset Family
Adapter Drivers	ialmrnt5
Adapter RAM	Unknown
Asynchronous Pan/Zoom	wheel input enabled; touch input enabled
Device ID	0x2772
Direct2D Enabled	Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer.
DirectWrite Enabled	false (0.0.0.0)
Driver Date	4-5-2005
Driver Version	6.14.10.4299
GPU #2 Active	false
GPU Accelerated Windows	0/1 Basic (OMTC) Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer.
Subsys ID	00000000
Supports Hardware H264 Decoding	No; Failed to initialize H264 decoder
Vendor ID	0x8086
WebGL Renderer	Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer.
windowLayerManagerRemote	true
AzureCanvasAccelerated	0
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
(#0) 	CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0

Comment 1

3 years ago
Are you sure this is using Flash? The error messages you describe are HTML <video> messages, and I believe vimeo is using native video for Firefox when able.

Is this a fresh Firefox profile? If so this may be caused by the period of time where we haven't yet installed the primetime CDM, which is required to decode H.264 video on Windows.
Flags: needinfo?(liviu.cirdei)
(Reporter)

Comment 2

3 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> Are you sure this is using Flash? The error messages you describe are HTML
> <video> messages, and I believe vimeo is using native video for Firefox when
> able.

I'm pretty sure it is flash, because if I disable flash player the video can't be played anymore (it shows "Uh Oh! This video can't be played with your current setup"). Also when right-clicking on the video with flash enabled I see "About Adobe Flash Player 21.0.0.197...". See the attached image.
> 
> Is this a fresh Firefox profile? If so this may be caused by the period of
> time where we haven't yet installed the primetime CDM, which is required to
> decode H.264 video on Windows.

Yes, it is a fresh Firefox profile. I can see the "Primetime Content Decryption Module provided by Adobe Systems, Incorporated" in the Plugins, if this is the one you are referring when saying "primetime CDM".
Flags: needinfo?(liviu.cirdei)
(Reporter)

Comment 3

3 years ago
Created attachment 8738524 [details]
with_flash.bmp

Comment 4

3 years ago
ok, since this has been identified as a regression in Firefox, next steps are to get a regression range. If you are able to use the tool at http://mozilla.github.io/mozregression/ that would be very helpful!
Flags: needinfo?(liviu.cirdei)
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 5

3 years ago
Hi, 

I mentioned in the initial report that I tried to find a regression range but all the builds downloaded by mozregression were good. I tried again today for several times and I got different results until I realized it's not always reproducible from the first time. Sometimes it reproduces after you close the vimeo tab, then open a new tab and play a video on vimeo, and so on.
I will try again to find a regression, but it will take some time.
Flags: needinfo?(liviu.cirdei)
(Reporter)

Comment 6

3 years ago
I found the regression:

Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cd2b53862f812ef4a522a39a5b2a3b3780099ed9&tochange=268f6f3364fdec329169a35d80462bb8637dd65b

Suspect: Bug 1234099 - Unhide Adobe GMP on Windows XP
Keywords: regressionwindow-wanted

Comment 7

3 years ago
Chris or Anthony, can you drive next steps on this? It seems to be some combo of tech-evang and maybe a primetime decoding issue.
Flags: needinfo?(cpeterson)
Flags: needinfo?(ajones)
I think this is two issues:

1. Firefox fails to decode Vimeo's H.264 video using the Adobe CDM due to a known CDM issue on some P4 machines and/or machines without SSE2. Adobe knows about the issue and it should be fixed in their next CDM release.

2. Vimeo then falls back to Flash, which is failing, probably due to the GPU driver issue mentioned in comment 0 ("Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer."). I would try updating the GPU drivers to fix Flash. That should not fix the Adobe issue, though.

@ Anthony: do you know if Adobe has fixed their decoding issues yet?
Flags: needinfo?(cpeterson)
Can you tell us the model number of your CPU? Not sure how to find that out in Windows XP.
The SSE2 issue triggers a plug-in crash. Do you see anything in about:crashes when this happens?
Flags: needinfo?(ajones)
Flags: needinfo?(liviu.cirdei)
(Reporter)

Comment 11

3 years ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #9)
> Can you tell us the model number of your CPU? Not sure how to find that out
> in Windows XP.

Intel Pentium 4 630, 3000 MHz

(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #10)
> The SSE2 issue triggers a plug-in crash. Do you see anything in
> about:crashes when this happens?

Yes. I can see crashes with the signature [@ mozilla::gmp::GMPChild::ProcessingError ]:

https://crash-stats.mozilla.com/report/index/deb80a3c-2b06-466f-b8c5-dd2e12160418
https://crash-stats.mozilla.com/report/index/f4f046c3-ad5e-4d70-80ef-461d62160418
https://crash-stats.mozilla.com/report/index/7511fa0b-6752-4809-9482-dd1052160418
Flags: needinfo?(liviu.cirdei)
Liviu - thanks for the info. We definitely seem to be having a problem with the Adobe H.264 decoder.

Chris - another Pentium 4 but we don't know if that is the problem.
Crash Signature: https://crash-stats.mozilla.com/report/index/deb80a3c-2b06-466f-b8c5-dd2e12160418 https://crash-stats.mozilla.com/report/index/f4f046c3-ad5e-4d70-80ef-461d62160418 https://crash-stats.mozilla.com/report/index/7511fa0b-6752-4809-9482-dd1052160418
Flags: needinfo?(cpearce)

Updated

3 years ago
Component: Plug-ins → Audio/Video: Playback
(Reporter)

Updated

3 years ago
Crash Signature: https://crash-stats.mozilla.com/report/index/deb80a3c-2b06-466f-b8c5-dd2e12160418 https://crash-stats.mozilla.com/report/index/f4f046c3-ad5e-4d70-80ef-461d62160418 https://crash-stats.mozilla.com/report/index/7511fa0b-6752-4809-9482-dd1052160418 → [@ mozilla::gmp::GMPChild::ProcessingError ]
Summary: Vimeo video using Flash player does not start on Windows XP when clicking "Play" button (low end machine) → Vimeo video using Flash player does not start on Windows XP when clicking "Play" button (low end machine w/o SSE2)
cpearce, is this bug specifically about SSE2? Can we WONTFIX this bug now that SSE2 will be a system requirement starting in Firefox 49?
We disabled the Adobe decoder so I think we can close this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #14)
> We disabled the Adobe decoder so I think we can close this bug.

Clearing ni? then.
Flags: needinfo?(cpearce)
Crash volume for signature 'mozilla::gmp::GMPChild::ProcessingError':
 - nightly (version 51): 80 crashes from 2016-08-01.
 - aurora  (version 50): 15 crashes from 2016-08-01.
 - beta    (version 49): 14 crashes from 2016-08-02.
 - release (version 48): 26 crashes from 2016-07-25.
 - esr     (version 45): 1 crash from 2016-05-02.

Crash volume on the last weeks (Week N is from 08-22 to 08-28):
            W. N-1  W. N-2  W. N-3
 - nightly       2       0      14
 - aurora        4       4       4
 - beta          4       5       5
 - release       9       1       1
 - esr           0       0       0

Affected platforms: Windows, Mac OS X, Linux

Crash rank on the last 7 days:
             Browser   Content Plugin
 - nightly                     #5
 - aurora                      #100
 - beta
 - release                     #104
 - esr
status-firefox49: --- → affected
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox-esr45: --- → affected

Updated

2 years ago
See Also: → bug 1330930
You need to log in before you can comment on or make changes to this bug.