If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

awesomebar results are not visually tied to the URL bar, giving a patchwork look and feel to the top-right of browser chrome

REOPENED
Unassigned

Status

()

Firefox
Address Bar
REOPENED
2 years ago
2 months ago

People

(Reporter: dietrich, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
On Mac the new awesomebar styling expands the results to the full length of the window, which visually disconnects it from the widget you're interacting with: the url input bar.

This gives a patchworky feel to the overall view of browser chrome on the top-right where the results meet the bottom of the navigation toolbar. The effect is more pronounced the more addons and icons you have to the right of the url bar.

Screenshot: https://i.imgur.com/HuEE9cz.png
I'm sorry but I fear this is a wontfix, we indeed exactly wanted that effect by design.
I think in general, we need more horizontal space for future contents.

If there are technical reasons that is bad, apart from personal taste, feel free to reopen and needinfo shorlander.
Blocks: 1262507
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

2 years ago
Reopening and NI shorlander :)

This bug is not asking to revert the expanding of the results to full window width.

This bug is polish about *how* it visually integrates with the other contents of that area.

The results panel is tied *directly* to the url bar in the nature of its existence, as triggered by a user action, but has acted out of character by jumping the tracks and expanding to the window width.

I'll think about some experiments to do to build a stronger visual relationship in the right side where the panel meets the bottom of the toolbar.
Flags: needinfo?(shorlander)
(Reporter)

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 3

a year ago
Created attachment 8778892 [details]
20160808-firefox-awesomebar.png

The position of the awesomebar dropdown is very jarring in my highly non-default configuration. See screenshot.

Observed behavior: the first row of tabs is partially visible between the location bar and the dropdown. The dropdown spans the whole window width, with its left half blank.

Also, try moving the location bar into the status bar. The dropdown (now more appropriately called “dropup”) is still at the top, far disconnected from the location bar.

Expected behavior:

* The dropdown should be vertically attached to the bottom or top of the location bar, whichever is nearer to the actual location of the dropdown.

* The dropdown’s left edge should be aligned to the left edge of the location bar and the right edge to the right edge of the window; or, alternatively, right edge aligned to the right edge of the location bar and the left edge to the left edge of the window; whichever gives more space for the dropdown contents.
You need to log in before you can comment on or make changes to this bug.