Closed Bug 12627 Opened 21 years ago Closed 21 years ago

core dump if mailto:-link was clicked

Categories

(Core :: Networking, defect, P3, major)

defect

Tracking

()

VERIFIED DUPLICATE of bug 12198

People

(Reporter: roland.mainz, Assigned: gagan)

References

()

Details

M9 build on Solaris 7 sparc dies with a core dump if a mailto:-href was clicked.
M9 build on WinNT 4SP3 dies silently on the same problem.

GDB produced the following info:
-- snip --
#0  0x0 in ?? ()
#1  0xfd796d40 in nsIOService::NewURI (this=0x83780, aSpec=0x2ca4e8
"mailto:jigsaw@informatik.med.uni-giessen.de",
    aBaseURI=0x0, result=0xffbee5cc) at
../../../../netwerk/base/src/nsIOService.cpp:208
#2  0x14f00 in NS_NewURI (result=0xffbee5cc, spec=0x2ca4e8
"mailto:jigsaw@informatik.med.uni-giessen.de", baseURI=0x0)
    at ../../../../netwerk/util/src/nsNeckoUtil.cpp:36
#3  0x14f48 in NS_NewURI (result=0xffbee5cc, spec=@0x2ca4e8, baseURI=0x0)
    at ../../../../netwerk/util/src/nsNeckoUtil.cpp:49
#4  0xff256bec in nsWebShell::LoadURL (this=0x445550, aURLSpec=0x534208,
aCommand=0xff25bf08 "view",
    aPostDataStream=0x0, aModifyHistory=1, aType=0, aLocalIP=0) at
../../../webshell/src/nsWebShell.cpp:2155
#5  0xff255fb4 in nsWebShell::LoadURL (this=0x445550, aURLSpec=0x534208,
aPostDataStream=0x0, aModifyHistory=1,
    aType=0, aLocalIP=0) at ../../../webshell/src/nsWebShell.cpp:1914
#6  0xff258584 in nsWebShell::HandleLinkClickEvent (this=0x445550,
aContent=0x2dfccc, aVerb=eLinkVerb_Replace,
    aURLSpec=0x534208, aTargetSpec=0x28f78, aPostDataStream=0x0) at
../../../webshell/src/nsWebShell.cpp:2988
#7  0xff257ebc in HandlePLEvent (aEvent=0x539018) at
../../../webshell/src/nsWebShell.cpp:2815
#8  0xfee63088 in PL_HandleEvent (self=0x539018) at plevent.c:509
#9  0xfee62f08 in PL_ProcessPendingEvents (self=0x9b110) at plevent.c:470
#10 0xfef033f0 in nsEventQueueImpl::ProcessPendingEvents (this=0xaaf88) at
../../../xpcom/threads/nsEventQueue.cpp:118
#11 0xff340e68 in event_processor_callback (data=0xaaf88, source=6,
condition=GDK_INPUT_READ)
    at ../../../../widget/src/gtk/nsAppShell.cpp:149
#12 0xfebcbf24 in gdk_io_invoke (source=0x109c18, condition=G_IO_IN,
data=0xded30) at gdkevents.c:878
#13 0xfeb55478 in g_io_unix_dispatch (source_data=0x1126e8,
current_time=0xffbeec20, user_data=0xded30) at giounix.c:135
#14 0xfeb57138 in g_main_dispatch (current_time=0xffbeec20) at gmain.c:652
#15 0xfeb57a24 in g_main_iterate (block=1228, dispatch=1) at gmain.c:870
#16 0xfeb57c34 in g_main_run (loop=0x111bd8) at gmain.c:928
#17 0xfecc5fbc in gtk_main () at gtkmain.c:475
#18 0xff3415e0 in nsAppShell::Run (this=0xa5d68) at
../../../../widget/src/gtk/nsAppShell.cpp:371
#19 0xfe57a064 in nsAppShellService::Run (this=0x83d20) at
../../../../xpfe/appshell/src/nsAppShellService.cpp:470
#20 0x141b4 in main1 (argc=0, argv=0xffbef0b4) at
../../../xpfe/bootstrap/nsAppRunner.cpp:761
#21 0x14384 in main (argc=1, argv=0xffbef0b4) at
../../../xpfe/bootstrap/nsAppRunner.cpp:828
-- snip --

Setting component to "Necko" (maybe I'm wrong, but...)
*** Bug 11884 has been marked as a duplicate of this bug. ***
Adding lchiang to cc: list in case she cares...
I care. There already is a bug on this.... I'll try to find it.
mailto: functionality is not implemented: see bug:
http://bugzilla.mozilla.org/show_bug.cgi?id=12580

However, we should not crash when clicking on mailto: (regardless if it works or
not).  That is bug http://bugzilla.mozilla.org/show_bug.cgi?id=12198.

This bug was marked fixed in M10 and didn't make it into M9.

I assume the problem here is that same as bug 12198.  Paulmac, will let you take
care of seeing if I'm right :-)
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Yes, it's the same. Thanks Lisa.

*** This bug has been marked as a duplicate of 12198 ***
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.