-204 NO_INSTALL_SCRIPT error when non-Latin-1 chars in temp directory name

VERIFIED FIXED

Status

Core Graveyard
Installer: XPInstall Engine
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: guivho, Assigned: Sean Su)

Tracking

({regression})

Trunk
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt1])

(Reporter)

Description

17 years ago
With the latest nightly builds, incl 2002021803 mozilla-win32-installer-sea.exe
I get following error early in the install process:

---------------------------
Error
---------------------------
Error occurred during installation - Mozilla XPCOM: -204 NO_INSTALL_SCRIPT
---------------------------
OK
---------------------------



I had to unzip the mozilla-win32-talkback.zip file into my mozilla directory to
be able to use the latest build.
Guido: am I understanding you correctly that this has happened in several
different builds?

If so I can't easily dismiss it as corruption during download, but then I'd
expect to get tons of reports which I haven't seen.

Anyone else reporting this? Anyone with a fast connection who could download the
2-18-03 Mozilla build's xpcom.xpi and see if there's an install.js file inside?

Guido: if you still have them please attach your install_status.log and
install_wizard#.log for the build that failed.

NO_INSTALL_SCRIPT is returned when we can't extract the install script. Usually
someone has forgotten to package one, but there could be other extraction
problems such as an inability to write to your temp directory. But if that were
the case I would have expected the downloads to fail first.
(Reporter)

Comment 2

17 years ago
I believe that this was just another manifestation of bug 126275 where the
%HOME%tmp was not properly expanded into c:/tmp 
This also caused mozilla to create a %home%tmp directory in the directory from
which the install was executed.
Problem does not occur anymore.
Installer now works fine, regardless of the way the TMP environment variable is
set. I now think that this was one of those MsDog things.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 3

17 years ago
worksforme
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → gbush

Comment 4

16 years ago
Sometimes it isn't working on Windows XP (got some reports from my users).
Mozilla 0.9.9 and 1.0RC1, please recheck this.

Comment 5

16 years ago
I've seen it todayon WindowsXP trying to install both 1.0rc1 and netscape6.2.2.

It was the Polish version of WinXP probably the same Marek Wawoczny has seen.
However, there are some similar problems recently reported on various newsgroups
reporded by users of English WindowsXP (see NO_INSTALL_SCRIPT using Google | Groups)

Reopening.
Status: VERIFIED → UNCONFIRMED
Resolution: FIXED → ---

Comment 6

16 years ago
Confirming myself per Marek's #4 comment as well as newsgroup reports.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
It's highly probable that the problem occurs when the user has WinXP login with
a non ISO-8859-1 character. The temp directory Mozilla tries to create on WinXP
has the user login in its name. 

Two users who had this problem (one I've tried to solve the problem for and one
I've contacted by email per his newsgroup question) both have Polish
(windows-1250) characters in the WinXP user name.

Comment 8

16 years ago
I've tested the problem. It turns out that a user without cp-1250 characters in
login (or "user name") can install Netscape6.2.2 and/or mozilla 1.0rc1, while
another user (both with administrative rerogatives0 on the same WinXP host) cannot.
Ah, wonderful news, thank you for narrowing this down! This will get fixed along
with bug 125106 -- as I started fixing it I went and fixed all similarly-broken
spots in the XPInstall engine. (When bug 100676 got fixed in XPCOM all the
XPInstall workarounds for it started doing the wrong thing.)
Status: NEW → ASSIGNED
Component: Installer → Installer: XPInstall Engine
Depends on: 125106
Keywords: regression
Summary: XPCOM: -204 NO_INSTALL_SCRIPT → -204 NO_INSTALL_SCRIPT error when non-Latin-1 chars in temp directory name
Fixed on the 1.0.0 branch with bug 125106, not yet on trunk
Keywords: fixed1.0.0

Comment 11

16 years ago
Guido, Marek or Jacek,

Would you verify that this is fixed on a branch build?  I am not seeing the 
problem here.

Comment 12

16 years ago
*** Bug 165733 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
The bug still exists in the current installer (rv:1.3 20030312).
->Sean

Sounds like 125106 was not landed entirely correctly on the trunk, or else maybe
the native installer is munging the paths passed in.
Assignee: dveditz → ssu
Status: ASSIGNED → NEW
Keywords: nsbeta1

Comment 15

15 years ago
Installer triage team: nsbeta1+/adt1
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt1]
(Assignee)

Comment 16

15 years ago
There's test build that I've done that has the patch from bug 125106 applied,
which should fix this bug too:
  ftp://ftp.mozilla.org/pub/mozilla/nightly/2003-04-14-16-trunk

Can someone try it out and let me know if it fixes this bug?
Status: NEW → ASSIGNED
(Assignee)

Comment 17

15 years ago
Bug 125106 has been fixed.  This bug should also be fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → FIXED

Comment 18

15 years ago
I have tried this with an user name which contains cp-1250 latin 2 characters by
install 05-01 trunk build on WinXP, I don't see the error message.  Looks like
it works for me.

Yuying
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.