Devtools: Debugger should automatically print expanded variable values next to source code

RESOLVED DUPLICATE of bug 1254658

Status

P3
normal
RESOLVED DUPLICATE of bug 1254658
3 years ago
4 months ago

People

(Reporter: nachtigall, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8739393 [details]
Chrome prints expanded variables in debugger

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

1. Open Debugger panel in devtools
2. Set breakpoint somewhere



Expected results:

I would like to have the variables automatically expanded to its values like Chrome does, see screenshot. This really eases debugging since I can easily see parameters passed to a function, or what the value of surrounding variables are. 

This is especially helpful if I do not know yet which variable might cause the error. Currently I can only investigate specific variable by selecting them using the "Variables" panel at the right side or use the mouseover popup. Both are great, but require more time and a deeper knowledgde of which variable you are interested in already which is - as said - not always known beforehand when debugging.

* The printed/expanded variables should be mouse hoverable and show the variables popup then
* it should also work for minified sources that are auto-prettified (Chrome doesn't do this atm) or prettified using a source map
(Reporter)

Updated

3 years ago
Blocks: 1074592
Component: Untriaged → Developer Tools: Debugger

Updated

3 years ago
Priority: -- → P3

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1254658

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.