Closed Bug 1263125 Opened 4 years ago Closed 4 years ago

Dropdown flickers when "Try Firefox Hello" pressed several times

Categories

(Hello (Loop) :: Client, defect, minor)

defect
Not set
minor

Tracking

(firefox45 affected, firefox46 affected, firefox47 affected, firefox48 affected)

RESOLVED WONTFIX
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- affected
firefox48 --- affected

People

(Reporter: cornel_ionce, Unassigned)

References

Details

[Affected versions]:
- Firefox 45.0.2
- Firefox 46 beta 9
- Latest 47.0a2 Aurora
- Latest 48.0a1 Nightly

[Affected platforms]:
- Windows 10 x86
- Windows 7 x64
- Ubuntu 14.04 x64
- Mac OS X 10.9.5

[Steps to reproduce]:
1. Open Firefox using a clean profile.
2. Visit https://www.mozilla.org/en-US/firefox/hello/
3. Press "Try Firefox Hello" several times.

[Expected result]:
The Hello dropdown opens/closes with each click.

[Actual result]:
The dropdown flickers instead of opening/closing (like both actions are performed).

[Regression range]:
Started to reproduce with Firefox 45 since it's the first version that supports Hello.

[Additional notes]:
- Works fine if the Hello icon is pressed several times
(In reply to Cornel Ionce [QA] from comment #0)
> [Steps to reproduce]:
> 1. Open Firefox using a clean profile.
> 2. Visit https://www.mozilla.org/en-US/firefox/hello/
> 3. Press "Try Firefox Hello" several times.

> [Expected result]:
> The Hello dropdown opens/closes with each click.

The "Try Firefox Hello" is expected to only open the panel...
 
> [Actual result]:
> The dropdown flickers instead of opening/closing (like both actions are
> performed).

This is expected. The first time you click the button, the panel opens. If you then click anywhere on the web page other than the try Firefox Hello button, the panel closes by itself.

If you then click the Try button again, it'll open the panel. However, when you then click the try button a second time, we're closing the panel (due to the click outside of the panel), and then opening the panel as a result of clicking the button.

The only other way to handle this that I can think of would be to not let the click event get to the page, but it seems that other Firefox panels work in a similar way - certainly the pocket and application menus do the action on the page even when the panel closes.

I think this is therefore wontfix for Hello. Although there could be something in how the panels are handled generally in Firefox that may be valid.

> [Regression range]:
> Started to reproduce with Firefox 45 since it's the first version that
> supports Hello.

Hello has been supported earlier than 45. Its just that 45 is the first version with the system add-on. However, that wouldn't affect this case.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1263126
You need to log in before you can comment on or make changes to this bug.