Associate user prompts with browser, and not with session

RESOLVED DUPLICATE of bug 1264259

Status

defect
RESOLVED DUPLICATE of bug 1264259
3 years ago
2 years ago

People

(Reporter: ato, Unassigned)

Tracking

(Blocks 1 bug, {pi-marionette-server})

Version 3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

The last raised user prompt/modal dialogue is currently associated with the session.  Because you can still change tabs with tab-modal dialogues, the dialogues need to be associated with the current browser (tab/window) instead.
This blocks the upcoming work for bug 1279211.
Blocks: 1279211
This can be resolved as part of rewriting the user prompt handler in
bug 1264259.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1264259
You need to log in before you can comment on or make changes to this bug.