Intermittent REFTEST TEST-UNEXPECTED-FAIL | grid-fragmentation-002.html | image comparison (==), max difference: 255, number of differing pixels: 9533

RESOLVED FIXED

Status

()

Core
Layout: Block and Inline
P4
minor
RESOLVED FIXED
2 years ago
10 months ago

People

(Reporter: reznord, Unassigned)

Tracking

({intermittent-failure})

unspecified
Unspecified
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox52 unaffected, firefox-esr52 unaffected, firefox53 fixed, firefox54 fixed, firefox55 fixed)

Details

(Whiteboard: [fixed by bug 1317149][stockwell disabled])

(Reporter)

Description

2 years ago
REFTEST TEST-UNEXPECTED-FAIL | file:///home/worker/workspace/build/tests/reftest/tests/layout/reftests/css-grid/grid-fragmentation-002.html | image comparison (==), max difference: 255, number of differing pixels: 9533

Treeherder Link: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&selectedJob=25636887
Component: JavaScript: Internationalization API → Layout: Block and Inline
The Treeherder link above gives me an error message: "Selected job id: 25636887 not within current result set range. Load result set".
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
Oh, I should also click "load result set".
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
layout/reftests/css-grid/grid-fragmentation-002.html is testing fragmentation of
grid-aligned abs.pos. children.  I'm not surprised this test failed since our
support for fragmentating abs.pos. is somewhat flaky in general (not just in Grid).
Severity: normal → minor
Priority: -- → P4
This becomes almost a permafail with my patchset for bug 1261279... not sure why
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4586dcdd79dc

Comment 5

a year ago
11 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 3
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 9
* linux64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2016-11-07&endday=2016-11-13&tree=all

Comment 6

a year ago
11 failures in 715 pushes (0.015 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* autoland: 5
* mozilla-inbound: 4
* mozilla-central: 1
* graphics: 1

Platform breakdown:
* windows7-32-vm: 6
* linux64: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2016-11-14&endday=2016-11-20&tree=all

Comment 7

a year ago
9 failures in 623 pushes (0.014 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* autoland: 5
* mozilla-aurora: 3
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 6
* linux64: 2
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2016-11-21&endday=2016-11-27&tree=all

Comment 8

a year ago
6 failures in 694 pushes (0.009 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-inbound: 2
* autoland: 2
* mozilla-central: 1
* mozilla-aurora: 1

Platform breakdown:
* linux64: 3
* windows8-64: 2
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2016-11-28&endday=2016-12-04&tree=all

Comment 9

a year ago
5 failures in 563 pushes (0.009 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-aurora: 3
* mozilla-central: 1
* autoland: 1

Platform breakdown:
* windows7-32-vm: 3
* windows8-64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2017-01-02&endday=2017-01-08&tree=all
8 failures in 722 pushes (0.011 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-inbound: 4
* mozilla-central: 2
* mozilla-aurora: 2

Platform breakdown:
* windows7-32-vm: 4
* windows8-64: 3
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2017-01-09&endday=2017-01-15&tree=all

Comment 11

11 months ago
This has been a low-frequency failure on Windows and Linux for a few months. There was a significant spike in failures, all on Android, beginning Feb 12. I don't see many failures today though, so this might not be an issue...will check back in a day or so...
Flags: needinfo?(gbrown)

Comment 12

11 months ago
Seems to be back to low frequency, desktop and Android now.
Flags: needinfo?(gbrown)

Comment 13

11 months ago
35 failures in 833 pushes (0.042 failures/push) were associated with this bug in the last 7 days. 

This is the #50 most frequent failure this week. 

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **

Repository breakdown:
* mozilla-inbound: 15
* autoland: 15
* mozilla-central: 4
* graphics: 1

Platform breakdown:
* android-4-3-armv7-api15: 28
* linux64: 4
* linux32: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2017-02-13&endday=2017-02-19&tree=all

Updated

11 months ago
See Also: → bug 1317149
and back to high frequency

Comment 15

11 months ago
7 failures in 812 pushes (0.009 failures/push) were associated with this bug in the last 7 days.  
Repository breakdown:
* autoland: 3
* mozilla-inbound: 2
* graphics: 2

Platform breakdown:
* linux32: 5
* windows7-32-vm: 1
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2017-02-20&endday=2017-02-26&tree=all
Whiteboard: [stockwell unknown]

Comment 16

11 months ago
5 failures in 783 pushes (0.006 failures/push) were associated with this bug in the last 7 days.  
Repository breakdown:
* try: 3
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* linux32: 3
* linux64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2017-02-27&endday=2017-03-05&tree=all

Comment 17

10 months ago
30 failures in 790 pushes (0.038 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 9
* mozilla-inbound: 7
* mozilla-central: 5
* oak: 4
* try: 3
* graphics: 2

Platform breakdown:
* android-4-3-armv7-api15: 19
* linux64: 6
* linux32: 3
* windows7-32-vm: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2017-03-06&endday=2017-03-12&tree=all
this picked up quite a bit, specifically on android debug reftest-26 :)

I am doing some retriggers here:
https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-searchStr=android%20debug%20reftest-26&tochange=45dc8c1db2792025efa14127d56626fd5c6f419a&fromchange=6c8cf852db30215ea93b6f63de157a00ec3f6020&selectedJob=82457518

we had a stylo reftest regression in the same window, this shouldn't be related, but... who knows :)
Whiteboard: [stockwell unknown] → [stockwell needswork]

Comment 19

10 months ago
I'm wallpapering this by commenting out the part of the test that fails, in bug 1317149.

Comment 20

10 months ago
Should be fixed by bug 1317149 now.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago10 months ago
Depends on: 1317149
Resolution: --- → FIXED
Whiteboard: [stockwell needswork] → [fixed by bug 1317149]
Whiteboard: [fixed by bug 1317149] → [fixed by bug 1317149][stockwell disabled]

Comment 21

10 months ago
14 failures in 777 pushes (0.018 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 5
* try: 3
* mozilla-inbound: 3
* mozilla-aurora: 2
* oak: 1

Platform breakdown:
* android-4-3-armv7-api15: 12
* windows7-32-vm: 1
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1264056&startday=2017-03-13&endday=2017-03-19&tree=all
status-firefox52: --- → unaffected
status-firefox53: --- → fixed
status-firefox54: --- → fixed
status-firefox55: --- → fixed
status-firefox-esr52: --- → unaffected
You need to log in before you can comment on or make changes to this bug.