Compositing garbage in the margins of a video

VERIFIED FIXED in Firefox 48

Status

()

defect
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: mstange, Assigned: sotaro)

Tracking

({regression})

Trunk
mozilla48
Points:
---

Firefox Tracking Flags

(firefox48 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Posted file testcase
STR:
 1. Load the testcase and wait for the video to load.
 2. Scroll up and down.

You'll see repeating borders and other garbage being composited around the video.

Looks like the video ImageLayer covers the whole <video> bounds and not just the part where the video will actually show.
(Assignee)

Updated

3 years ago
Assignee: nobody → sotaro.ikeda.g
Duplicate of this bug: 1264140
(Assignee)

Updated

3 years ago
Attachment #8740769 - Flags: review?(matt.woodrow)
Attachment #8740769 - Flags: review?(matt.woodrow) → review+
Comment on attachment 8740769 [details] [diff] [review]
patch - Add ImageLayerComposite::GetFullyRenderedRegion()

Review of attachment 8740769 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/composite/ImageLayerComposite.cpp
@@ +177,5 @@
> +  }
> +
> +  if (mScaleMode == ScaleMode::STRETCH) {
> +    nsIntRegion shadowVisibleRegion = GetShadowVisibleRegion().ToUnknownRegion();
> +    shadowVisibleRegion.And(shadowVisibleRegion, nsIntRegion(gfx::IntRect(0, 0, mScaleToSize.width, mScaleToSize.height)));

You can avoid a copy by doing:
nsIntRegion shadowVisibleRegion;
shadowVisibleRegion.And(GetShadowVisibleRegion().ToUnknownRegion(), nsIntRegion(gfx::IntRect(0, 0, mScaleToSize.width, mScaleToSize.height)));
(Assignee)

Comment 4

3 years ago
Thanks. I am going to update the patch.
(Assignee)

Comment 5

3 years ago
Apply the comment. Carry "r=mattwoodrow".
Attachment #8740769 - Attachment is obsolete: true
(Assignee)

Updated

3 years ago
Attachment #8740784 - Flags: review+

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/14d19fb83d3a
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Duplicate of this bug: 1264463
QA Whiteboard: [good first verify]
I have reproduced this bug with Firefox nightly 48.0a1(build id:20160412030235)on
windows 7(64 bit)

Verified this bug as fixed with Firefox beta 48.0b3(build id:20160623122823)
User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Verified as fixed with Firefox aurora 49.0a2(build id:20160723004004)
User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

[testday-20160722]
Reproduced this issue in firefox aurora 48.0a1 (2016-04-12) with ubuntu 16.04 (64 bit)

Verified as this issue fixed with latest firefox beta 48.0b9 (Build ID: 20160718142219)
Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0

As it is also verified on windows (Comment 9), Marking it as verified!
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify] → [good first verify] [testday-20160722]
You need to log in before you can comment on or make changes to this bug.