Closed Bug 126475 Opened 18 years ago Closed 17 years ago

Occurrences of uninitialized variables being used before being set (in intl)

Categories

(Core :: Internationalization, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 191712

People

(Reporter: mozilla-bugs, Assigned: smontagu)

Details

(Keywords: intl)

This bug is just for the warnings in various source files in
intl directory. Currently
(http://tinderbox.mozilla.org/SeaMonkey/warn1014136200.29882.html - Tue, 19 Feb
2002 11:30 EST) TBox shows the following warnings:

intl/locale/src/unix/nsDateTimeFormatUnix.cpp:189
 `nsresult res' might be used uninitialized in this function

intl/unicharutil/src/nsBidiImp.cpp:858
 `DirProp beforeNeutral' might be used uninitialized in this function

intl/unicharutil/src/nsBidiUtilsImp.cpp:357
 `PRInt8 leftNoTrJ' might be used uninitialized in this function

intl/unicharutil/src/nsBidiUtilsImp.cpp:518
 `PRUint32 beginArabic' might be used uninitialized in this function

intl/unicharutil/src/nsBidiUtilsImp.cpp:575
 `PRUint32 beginArabic' might be used uninitialized in this function

intl/unicharutil/src/nsBidiUtilsImp.cpp:607
 `PRUint32 beginNumeral' might be used uninitialized in this function
Bug 59652 is the meta-bug tracking the fight against these (potentially very
nasty) warnings.

P.S. Trying to make sure that 1.0 has as little warnings as possible.


Blocks: 59652
Keywords: mozilla1.0
The Bidi warning have just disappeared after check-in to bug 120818 moved those
files into new locations. I do not know if the warnings are still there in the
moved files.

P.S. See also bug 126484 that documents similar warnings in the
nsBidiPresUtils.cpp file.
Should IQA be involved in this bug?
Keywords: intl
ruixu: I'll change the QA contact to Frank
smontagu:  can you try to see if any warnings?
assigning to smontagu
Assignee: yokoyama → smontagu
QA Contact: ruixu → ftang
Status: NEW → ASSIGNED
Summary: Occurances of uninitialized variables being used before being set (in intl) → Occurrences of uninitialized variables being used before being set (in intl)
The last warning in intl was fixed in bug 191712.

*** This bug has been marked as a duplicate of 191712 ***
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
No longer blocks: 59652, 179819
You need to log in before you can comment on or make changes to this bug.