Closed Bug 191712 Opened 17 years ago Closed 17 years ago

nsDateTimeFormatUnix returns an uninitialized value in an error case

Categories

(Core :: Internationalization, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

()

VERIFIED FIXED

People

(Reporter: timeless, Assigned: timeless)

References

Details

Attachments

(3 files)

while i was rebuilding i noticed this warning...
Attached patch patchSplinter Review
move check for mDecoder to the beginning
Attachment #113382 - Flags: superreview?(alecf)
Attachment #113382 - Flags: review?(smontagu)
Comment on attachment 113382 [details] [diff] [review]
patch

sr=alecf
Attachment #113382 - Flags: superreview?(alecf) → superreview+
Comment on attachment 113382 [details] [diff] [review]
patch

r=smontagu
Attachment #113382 - Flags: review?(smontagu) → review+
checked in
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
*** Bug 126475 has been marked as a duplicate of this bug. ***
Blocks: 59652
V, warning went away on brad TBox.
Status: RESOLVED → VERIFIED
If i build with this (/nsDateTimeFormatUnix.cpp/1.50/Sun Feb 23 13:45:16 2003//)
i crash when selecting mails. Complete blocker. 
A couple of times i didn't crash on the first mail i selected, but on the second
one. Once i froze instead, and the date stamp in the mail i'd clicked on then
looked like one very long string of chinese.

This checkin looked interesging so i backed it out: voila - no more crash.
I then updated to v 1.50 again, and once again i crash.

Linux, trunk CVS, running on RH8.
ac_add_options --disable-accessibility
ac_add_options --disable-postscript
ac_add_options --disable-ldap
ac_add_options --disable-debug
ac_add_options --disable-tests
ac_add_options --disable-logging
ac_add_options --enable-crypto
ac_add_options --enable-optimize=-O2
ac_add_options --disable-bidi
ac_add_options --disable-jsd
ac_add_options --disable-mathml
i do not crash with official build 2003022222. Clobbering now.
Still crashes.
and... now it works.

I re-pulled, removed "disable-bidi" since it has no effect anymore, changed LANG
to no_NO, and a new build then worked.

Re-instated disable-bidi and rebuilt: Still no crash.
I doubt the LANG environment caused this.
And i can't see anything in the newer checkins?
oh.. i CAN see the new checkin - 1.51
You need to log in before you can comment on or make changes to this bug.