Closed Bug 1265028 Opened 4 years ago Closed 3 years ago

Bump Firefox Puppeteer to 49.0.0 and release to PyPI

Categories

(Testing :: Firefox UI Tests, defect)

Version 3
defect
Not set

Tracking

(firefox49 fixed, firefox50 fixed)

RESOLVED FIXED
mozilla50
Tracking Status
firefox49 --- fixed
firefox50 --- fixed

People

(Reporter: davehunt, Assigned: whimboo)

References

Details

Attachments

(1 file)

Once bug 1144873 is resolved, we'll need a new release of Firefox Puppeteer to start running tests for installing add-ons from https://addons.mozilla.org/ and other environments.
I have some other necessary fixes to land for puppeteer which fix regressions. So lets get them in before releasing a new version. The fix for bug 1270256 might also affect the harness, but adding it here nevertheless. 

Also I would like to solve bug 1265031 first which is about the versioning schema. Right now it's indeed not that clear.
Dependencies have been fixed and we should be good to get a new release out. I will only wait for the next nightly builds for mozilla-central and mozilla-aurora before getting a new release out. In the meantime lets already upload the patch and get it reviewed.
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Summary: Bump version number and release a new version of Firefox Puppeteer to PyPI → Bump Firefox Puppeteer to 49.0.0 and release to PyPI
Comment on attachment 8753996 [details]
MozReview Request: Bug 1265028 - Bump Firefox Puppeteer to 49.0.0. r?maja_zf

https://reviewboard.mozilla.org/r/53642/#review50404
Attachment #8753996 - Flags: review?(mjzffr) → review+
All dependencies have been fixed. Sadly we missed to land the patch before the merge on Monday last week. So meanwhile we would need 50.0 as release. But to make it easier for backporting I will land and backport this patch anyway, and follow-up on another bug with a 50.0 release.
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6b692021a1cd
Bump Firefox Puppeteer to 49.0.0. r=maja_zf
maja, henrik this cause  15:52:37 INFO - Could not find a version that satisfies the requirement firefox-puppeteer==4.0.0 (from external-media-tests==2.0->-r /builds/slave/test/build/tests/config/external-media-tests-requirements.txt (line 2)) (from versions: 2.0.0, 3.1.0, 3.2.0, 3.0.0, 2.0.0, 3.1.0, 3.2.0, 3.0.0, 2.0.0, 3.1.0, 3.2.0, 3.0.0, 2.0.0, 3.1.0, 3.2.0, 3.0.0) 

but its tier-2 so no backout so far :) but i guess still worth to look into
Flags: needinfo?(hskupin)
Looks like its because we have too strict version requirements. We always would have to make sure to update all consumers too for version bumps. As Maja said on IRC the media tests requirements file would need an update:

https://dxr.mozilla.org/mozilla-central/source/dom/media/test/external/requirements.txt
Flags: needinfo?(hskupin)
A fix for this regression is up on bug 1280017 now.
I uploaded the 49.0.0 release to pypi in the hope that there is some other piece in media tests which still want to download the release.

Uploading distributions to https://pypi.python.org/pypi
Uploading firefox_puppeteer-49.0.0-py2-none-any.whl
Uploading firefox-puppeteer-49.0.0.tar.gz
Keywords: leave-open
https://hg.mozilla.org/mozilla-central/rev/6b692021a1cd
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
We need this testing patch including the ones on bug 1280017 backported to aurora.
Whiteboard: [checkin-needed-aurora]
You need to log in before you can comment on or make changes to this bug.