Widevine CDM (version 1.4.8.885) crashes in mozilla::WidevineDecryptor::Decrypt() when loading Amazon Video page on Windows

RESOLVED FIXED

Status

()

P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: cpeterson, Assigned: cpearce)

Tracking

(Blocks: 1 bug, {crash})

Trunk
Unspecified
Windows
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 ?, firefox48 affected)

Details

(crash signature)

(Reporter)

Description

2 years ago
STR:
1. On Windows, load www.amazon.com/dp/B00RSGIVVO/

RESULT:
CRASH! bp-6843d0b0-ced6-4810-98c8-a58002160414

This crash is a regression with Widevine version 1.4.8.885. The previous version, 1.4.8.866, does not crash. I was not able to reproduce the crash on OS X.

Frame 	Module 	Signature 	Source
0 	widevinecdm.dll 	widevinecdm.dll@0xaad95 	
1 	widevinecdm.dll 	widevinecdm.dll@0xa1a27 	
2 	widevinecdm.dll 	widevinecdm.dll@0xa154d 	
3 	widevinecdm.dll 	widevinecdm.dll@0xa1456 	
4 	xul.dll 	mozilla::WidevineDecryptor::Decrypt(GMPBuffer*, GMPEncryptedBufferMetadata*) 	dom/media/gmp/widevine-adapter/WidevineDecryptor.cpp 
...
(Reporter)

Updated

2 years ago
Crash Signature: [@ widevinecdm.dll@0xaad95 ]
(Assignee)

Updated

2 years ago
Priority: -- → P1
(Reporter)

Updated

2 years ago
Blocks: 1264851
(Reporter)

Comment 1

2 years ago
A Google engineer is investigating this CDM crash.
Summary: Widevine CDM crashes in mozilla::WidevineDecryptor::Decrypt() when loading Amazon Video page on Windows → Widevine CDM (version 1.4.8.885) crashes in mozilla::WidevineDecryptor::Decrypt() when loading Amazon Video page on Windows
(Reporter)

Updated

2 years ago
Depends on: 1273214
(Assignee)

Comment 2

2 years ago
Fixed by us shipping Widevine CDM 893.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.