Open Bug 1265324 Opened 5 years ago Updated 2 years ago

[e10s] Typing is garbled after backspacing

Categories

(Core :: DOM: Content Processes, defect, P2)

Unspecified
All
defect

Tracking

()

REOPENED
Tracking Status
platform-rel --- -
e10s + ---
firefox48 --- affected

People

(Reporter: djc, Unassigned)

References

Details

(Keywords: qawanted, Whiteboard: btpp-followup-2016-04-29)

Attachments

(1 file)

With e10s enabled on Nightly, typing in the Twitter Web Tweetbox, I often manage to "break" typing. Specifically, quickly typing a sentence, then keeping backspace depressed for a little bit, then quickly resuming typing, some letters end up after the caret. Clearly this shouldn't be the case. I am able to reproduce this somewhat reliably. Apparently input events are not necessarily handled in order?
Blocks: e10s
This doesn't sound like an e10s problem. Have you tested with e10s disabled? Also, can you provide a URL where it happens? I'm not too familiar with Twitter.
Flags: needinfo?(dirkjan)
I have tested with e10s disabled, and was unable to reproduce it there. Also anecdotally from my memory, I've only been seeing this since about the time I started using e10s. I see it happening just on https://twitter.com/, when I'm logged in, typing into the text box for status updates.
Flags: needinfo?(dirkjan)
tracking-e10s: --- → ?
please test on slower systems.
Keywords: qawanted
Whiteboard: btpp-followup-2016-04-29
Flags: needinfo?(florin.mezei)
Discussed with Rares (they have some older and slower machines). Assigning this to Liviu to try it on our slow Windows machine.
Flags: needinfo?(florin.mezei) → needinfo?(liviu.cirdei)
FWIW, I see this on late 2013 or mid-2014 rMBPs, so machines that are not that slow. I tried again to reproduce it in three scenarios, about 14 tabs open in total:

- Normal browser window, e10s enabled: can reproduce
- Safe mode browser window, e10s enabled: can reproduce
- Normal browser window, e10s disabled: cannot reproduce

This machine has a 2Ghz Core i7 with 8GB RAM, Intel Iris Pro GPU.
On what OS is this reproducible? 
From comment 5 I can understand this is not related to a slow machine so I've tried on Windows 10 x64 (Intel Core i5, 16 Gb RAM) with latest Nightly (Build ID 20160502030207) and I could not reproduce the problem.
Flags: needinfo?(liviu.cirdei)
This is on OS X.
Flags: needinfo?(twalker)
User Agent  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID  20160504043118

I tested on a Mac OS X 10.9 (2.3 Ghz Intel Core i5, 6Gb RAM)  using latest Nightly and I could not reproduce the issue. Maybe someone else could also try.
OS: Unspecified → Mac OS X
I am also unable to reproduce this on Mac 10.11, Nightly 49.0a1, 20160504043118.

djc,  I see you have reproduced in safemode.  Can you try in a new/clean profile?
Flags: needinfo?(twalker) → needinfo?(dirkjan)
Please reopen if you still see this.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Still seeing this on two different (but similar) machines. However, even though I spent some time reproducing in a clean session, I was unable to do so.
Status: RESOLVED → REOPENED
Flags: needinfo?(dirkjan)
Resolution: WORKSFORME → ---
Michelle, can your team try to reproduce this on the low-end machines in your possession?
Flags: needinfo?(mfunches)
Attached video 2016-06-02_14-43-54.mp4
Tested on:

Version     49.0a1
Build ID     20160602030220
User Agent     Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 

Graphics:

PROCESSOR: 	N3050@1.60GHz
RAM: 	2GB
GRAPHICS: 	Intel HD Graphics Direct3d11 
BUILD ARCH: 	Version 10.0 - 10240

Steps to reproduce:

1. Open a Twitter textbox
2. Start fast typing a random sentence/word 
3. Press backspace for few seconds

Observed:

Continuous backspace skips character. After skipping, cursor retains the current position. Any character(s) typed from current position displays correctly but always include the skipped character as the last one(skipped character doesn't get overwritten).

Other Notes:
e10s enabled
Add-On installed: Amazon Assintant for Firefox, FireGesture,RESTClient,         FireGesture, Speed Dial
Flags: needinfo?(mfunches)
OS: Mac OS X → All
Priority: -- → P1
Whiteboard: btpp-followup-2016-04-29 → btpp-followup-2016-04-29, e10st?
Duplicate of this bug: 1286116
See Also: → 1284374
Cannot reproduce on my machines (Linux/MacOS/Windows).

Tried this in a high memory pressure page (by continuously creating many garbage JS object), or call NS_ProcessNextEvent in the keyboard event handlers, but it works normally.

Also checked if there are some keyboard IPC messages passed in different priorities, but seems there is only one IPC message related to keyboard.
In bug 1284374 I am starting to narrow down a similar issue to a feature in the antivirus. Could that be the same here? (It still requires the browser to have slight pausing issues)
Whiteboard: btpp-followup-2016-04-29, e10st? → btpp-followup-2016-04-29
platform-rel: --- → ?
platform-rel: ? → -
Priority: P1 → P2
I haven't reproduced this in a looong time (despite still using the same machines). Maybe just resolve it as WORKSFORME?
You need to log in before you can comment on or make changes to this bug.