Closed Bug 1265508 Opened 6 years ago Closed 3 years ago

Attempt to add custom search engine (DuckDuckGo) has no effect in Thunderbird 45 OpenSearch

Categories

(Thunderbird :: General, defect)

45 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1427317

People

(Reporter: erik.brangs, Unassigned)

References

()

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160407164938

Steps to reproduce:

I'm trying to add DuckDuckGo as a search engine option in Thunderbird 45 on Windows 7 64-bit. I'm using the instructions from https://duck.co/help/desktop/thunderbird which seem to be based on https://support.mozilla.org/en-US/kb/add-search-engine-open-search . I'm using Thunderbird with German localization.


Actual results:

I tried all the steps from the instructions but they don't work: I can't choose DuckDuckGo as a search engine because it's not listed.


Expected results:

I would have expected the steps to add DuckDuckGo as a potential search engine. I'm pretty confident that the instructions are correct because I tried them on an Ubuntu 16.04 system with Thunderbird 38.6.0 and they worked on that system.

If something has changed in Thunderbird 45, I would have expected the documentation on Mozilla's website to be updated.
Thunderbird User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.0
Thunderbird Build ID: 20160407161913
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Component: Untriaged → General
Summary: Attempt to add custom search engine (DuckDuckGo) has no effect in Thunderbird 45 → Attempt to add custom search engine (DuckDuckGo) has no effect in Thunderbird 45 OpenSearch
Keywords: regression
This is because of a change in Firefox 45. "Firefox 45 for developers" says.

"Starting in Firefox 45, search plugins located in the user's profile's searchplugins directory are no longer automatically loaded on startup. Instead, a list of user-installed plugins is maintained and only those plugins are loaded."
https://developer.mozilla.org/en-US/Firefox/Releases/45#Search_plugins

So there is currently no UI to add custom search engines from a custom_search_engine.xml file. But a workaround for Firefox is given in https://bugzilla.mozilla.org/show_bug.cgi?id=1236498#c7

In Thunderbird
1. Tools > Error Console (Ctrl+SHift+J)
2. Type in the "Code:" line:
Components.utils.import("resource://gre/modules/Services.jsm"); Services.search.addEngine("file:///path/to/your/custom_search_engine.xml", null, null, true);
3. Press "Evaluate"
Thank you. The workaround worked for me.
I believe the most-correct way to do it is to create an add-on like we did for Google: https://addons.mozilla.org/en-US/thunderbird/addon/google-search-for-thunderbi/
I'm not sure about the best way to fix this. However, I think that the documentation in Mozilla Support and/or the release notes really should be updated to mention how it's supposed to work in Thunderbird 45.
Can you not just add Duck Duck Go as one of the predefined search engines?
Thunderbird 60.3.1
What the hell is needed to remove the default search engines and add custom ones from an admin point of view?!

- The steps provided by neomjp above do NOT work for current version.
- The steps in https://support.mozilla.org/en-US/kb/add-search-engine-open-search do NOT work either !
- We do NOT want to use addons for simple things like search providers which are only simple xml files.

Mostly a duplicate of bug 1427317 but Bug 1427133 added DuckDuckGo and Google as default search engines.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1427317
You need to log in before you can comment on or make changes to this bug.