Closed Bug 1265891 Opened 4 years ago Closed 3 years ago

Missing Bulgarian language in the list of available languages on MDN

Categories

(developer.mozilla.org :: Localization, enhancement)

All
Other
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: k.berov, Assigned: jwhitlock)

References

Details

(Keywords: in-triage)

:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

There is no Bulgarian(Български) language to the list of available languages on MDN.
I would like to translate some pages to Bulgarian.
Example start page: https://developer.mozilla.org/en-US/docs/Web
Please add bg_BG to the available languages for localizing pages on MDN.
Thank you!
Severity: normal → enhancement
Priority: P5 → P4
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: P4 → --
Product: Developer Documentation → Mozilla Developer Network
Following the product-details project [1], we'd use "bg" for the language code. There are three contributors of Bulgarian localizations [2].  This is a small team to translate the almost 1000 strings in the MDN UI.

[1] http://viewvc.svn.mozilla.org/vc/libs/product-details/json/languages.json?view=markup#l42
[2] https://pontoon.mozilla.org/bg/contributors/
Thanks! Thanks for the info too! I will try to contact them.
Any progress on this?
I wonder why adding several letters to a menu should take months?
Isn't there anyone who can spend several minutes on this, or I misunderstand something.
Can I do it myself?
Two writing systems (one of them the Cyrillic alphabet (азбука)) were invented in Bulgaria and it is a shame to not have the ability to add Bulgarian translation.
Ok, just my thoughts.

Thanks!
Please note, I would like to be able to translate content as well as the UI strings/messages.
Thanks again.
I initiated the request for adding MDN to Pontoon [1]. There you will be able to translate the UI. As for the articles you cat head to [1]

[1] https://pontoon.mozilla.org/bg
[2] https://developer.mozilla.org/en-US/docs/MDN/Contribute/Localize/Translating_pages
Thank you , @stoyan.
The problem is that there is no [български]  on the language page.
"2. Click the language that you want to translate the page into. The Translating Article view opens with the original language text displayed on the left side of the view."
See https://developer.mozilla.org/en-US/docs/MDN/Contribute/Localize/Translating_pages$locales

That is why I created this issue. 
There is no possibility to translate content in Bulgarian as there is no item [български] on the language page.

Thanks,
Krasimir
John, can you confirm that UI translation is a prerequisite for adding Bulgarian to the list of available content languages?
Flags: needinfo?(jwhitlock)
We discussed adding new locales at our in-person meeting last month, and decided that we needed to study the issue before adding further locales. We haven't started this research yet, so I don't have a list of "if you do this, we'll add Bulgarian" yet.
Flags: needinfo?(jwhitlock) → needinfo?(a.topal)
Our aim is to commit keeping up to date just a small subset of pages related to HTML, JavaScript and CSS and the interface, of course.
Hello :)

Sorry for the very late answer. The MDN team has finally agreed on a process to add a new locale to MDN (see: https://developer.mozilla.org/en-US/docs/MDN/Contribute/Localize/Starting_a_localization)

I think you match pretty much all the criteria. I encourage you to review it and to introduce the Bulgarian team and project on the dev-mdc mailing list (https://lists.mozilla.org/listinfo/dev-mdc)

The UI strings for Bulgarian are already available on Pontoon (https://pontoon.mozilla.org/projects/mdn/) now the challenge is to have at least 50% of them localized.
Marry Christmas to all who celebrate it! 
Честито Рождество Христово!

This message is just to inform you that we have more than 50% of the MDN UI translated.
I was looking for a staging server where I can see the strings in use, but did not find such staging server with Bulgarian enabled.
@jeremie, now I'm re-reading https://developer.mozilla.org/en-US/docs/MDN/Contribute/Localize/Starting_a_localization
to see what's next.
Flags: needinfo?(stoyan)
We don't have a staging server with Bulgarian enabled. Enabling candidate languages on the staging server feels like a good idea to me. We also need to add "bg" as a candidate language:

https://github.com/mozilla/kuma/blob/master/kuma/settings/common.py

I'll take to bug to remind me to do this in January, when staff is back from the end-of-year break.
Assignee: nobody → jwhitlock
Flags: needinfo?(stoyan)
I've enabled Bulgarian on the staging server, so now you can see the translated UI strings in context:

https://developer.allizom.org/bg/#
@jwhitlock, Thank you!
I used this instance to see how translated strings look in context. I translated the missing (not translated) strings in the front-page and more. I also browsed and translated wherever I could see not translated strings. 

Now we have 60% of the UI translated in Bulgarian.

But because the instance does not allow me to play with the content I could not see much more to translate/ change adequately. It also looks like this instance is not automatically updated with new translations, because for several days I didn't see my updated strings after refreshing the page

I think we can/should go further and put bg in the production instance.
This way I can start translating some of the articles, beginning with the featured on the landing page of MDN.
This way I could attract contributors, by showing that there is already something done, and can blog about it in different places etc.

BTW, can some of you vouch for me https://mozillians.org/en-US/u/berov/ ?
I've vouched for you on Mozillians.org. Do you have other people working with you on the translations? I strongly encourage you to find people to help you, because it's both more fun and more sustainable.
The translations are not automatically deployed to the staging server, but are deployed when we deploy other code.  We usually deploy at least once a week.

I've recently deployed your new strings, so they should be available on the staging site.

I think the needinfo for atopal was to document the process, which I believe is now documented at https://developer.mozilla.org/en-US/docs/MDN/Contribute/Localize/Starting_a_localization. 

I believe the next step in the process is to open a new bug to enable the language on the production site.
Flags: needinfo?(a.topal)
Thank you Janet!
Thank you John!
I just created https://bugzilla.mozilla.org/show_bug.cgi?id=1339948
After we enable the language on MDN I can spread the good news.

Regards!
Blocks: 1339948
See Also: → 1340003
Closing in favor of bug 1339948.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.