If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Include the w3c validator in Mozilla

RESOLVED DUPLICATE of bug 73105

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 73105
16 years ago
13 years ago

People

(Reporter: mgueury, Assigned: Matthew Paul Thomas)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I think too that Mozilla should contain the real W3C validator of W3C.
I personally think without modification. (unlike bug 114188)

It gives a lot of advantages as web developer:
- you can see if you generates real HTML pages.
- you can correct them and explain why it is wrong without any help.
- you can use it to point to other people why their pages are wrong.
- if it is included inside mozilla, you can even do it for intranet site.
- you can detect easily very buggy page with unclosed tags and so on.

Comment 1

16 years ago
This sounds like a horrible bloat. Mozilla as such isn't a development tool. 
Furthermore: A developer would likely have access to the real thing at all
times, so why slow mozilla down with an additional copy.

Also note that the product and component for bug 114188 is "Mozilla.org" and
"Miscallenous" - not anything to do with the browser product.

Recommend WONTFIX!

Comment 2

16 years ago
What about having a sidebar tab that, when open (and only then), automatically
calls the w3c validator and displays the result in the sidebar tab? This way
there would be no bloat and the validation would only happen when requested by
opening the tab.

Comment 3

16 years ago
See also bug 73105, bug 47108, and bug 6211.
-> mpt
Assignee: asa → mpt
Severity: normal → enhancement
Component: Browser-General → User Interface Design
QA Contact: doronr → zach
Duping.  I think the various bugs mentioned here cover all the ground this could.

*** This bug has been marked as a duplicate of 73105 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.