No way to disable Alexa domain autocomplete suggestions

RESOLVED WONTFIX

Status

()

Firefox for Android
Settings and Preferences
RESOLVED WONTFIX
2 years ago
2 months ago

People

(Reporter: Jerod Lycett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8744864 [details]
Filling domain

Even with search suggestions unchecked domains still get suggested. This behavior occurs in Aurora and Nightly, but not Beta nor Release.
I think this is intentional. The initial list of domains to autocomplete is shipping with the app (~ Alexa top sites, no network request needed). Setting tracking flag so that this can be discussed during triage.
tracking-fennec: --- → ?

Comment 2

2 years ago
I don't think we should conflate domain autocomplete with search suggestions in a single pref, and I'm hesitant to add another pref for domain autocompletion.

I think we should probably just WONTFIX this. Barbara, what do you think we should do?
Flags: needinfo?(bbermes)
Summary: Show search suggestions unchecked being ignored → Search suggestions pref does not apply to Alexa domain autocomplete suggestions
Duplicate of this bug: 1270574

Comment 4

2 years ago
This is a bad and unexpected decision. Rather than repeat myself, please read the linked duplicate.
Is the issue about the domain autocomplete ".com" (highlighted) in the screenshot or the duckduckgo "about" pill that shows up?

I agree with Margaret that the domain autocomplete is not the same as search suggestion and thus should not be considered one pref.
Flags: needinfo?(bbermes)
The domain in the address bar which the user did not type. For a better example type q in the address bar on a clean profile. From the Alexa top 1k we get QVC https://en.wikipedia.org/wiki/QVC

Comment 7

2 years ago
IMO this "feature" should be removed completely. I consider it SPAM.

Updated

2 years ago
Summary: Search suggestions pref does not apply to Alexa domain autocomplete suggestions → No way to disable Alexa domain autocomplete suggestions
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Comment 8

2 years ago
A bad decision for sure.
tracking-fennec: ? → ---
Duplicate of this bug: 1279415

Comment 10

a year ago
Terrible feature. It *is* spam, and it sends me to sites that I don't want to visit.

It's a problem for several reasons:

1. It sends me to sites that I would never visit. If I want to search for "net", I type in n-e-t and hit enter and end up on Netflix, instead of search results. I don't use that service, I do not consent to their TOS, so I should not be tricked into visiting that site. There are many worse examples.

2. If I were to run a popular site called, "net_world.com" (fake domain), Firefox would be sending a significant number of my users to different site (Netflix, for example) when they tried to visit "net_world.com" -- negatively affecting my traffic.

3. It would be just a small additional step to begin to insert additional websites there for payment, which would influence the behavior of non-savvy users who will end up on those sites without even realizing what happened. Corruption can be tempting when it's too easy.

4. It slows users down by increasing cognitive load and forcing them to hit extra keys on a large percentage of searches.

5. The feature is terrible for Firefox in general. It's things like this that make long-time, tech savvy Firefox supporters start to hate the browser. If you build features for the least tech-savvy users, with no way for power users to turn them off, you start to lose your core supporters. Basically, you're injecting about 990 websites that I don't like into my bookmarks.

Please at least add a way to turn it off in a setting. My URL bar should only fill URLs that I have previously visited or that are in my bookmarks – otherwise it should perform a search.

Comment 11

5 months ago
The upcoming desktop implementation of this will include a pref. to disable it: https://bugzilla.mozilla.org/show_bug.cgi?id=1211726

That makes the WONTFIXing of this because of being "hesitant to add another pref for domain autocompletion" far less tenable, since the absence of a pref just trades the extra pref "problem" for different one of making FFfA less consistent with its desktop counterpart instead. And at least with the pref, it would be more useful.

I mentioned it on the above-mentioned bug, but apart from the annoyance factor (why is there **** in my autocomplete I have never visited and never want to?), the preseed also helps entrench *for all new users* the dominant commercial entities whose domains start with their business type.

* "Hey, I want to open a new bank account"
* b..a...n...
* ...kofamerica.com

-> Bank of America gets free advertising because they have the right company name/domain name structure and are big enough to be high up on Alexa and therefore included/suggested.

Other examples: Credit Karma. Auto Trader. Mail Chimp. Bed Bath and Beyond. Cars.com. Etc. etc.

Comment 12

5 months ago
> Bank of America gets free advertising... Other examples: Credit Karma. Auto Trader. Mail Chimp. Bed Bath and Beyond. Cars.com. Etc. etc.

It is a serious problem.
You need to log in before you can comment on or make changes to this bug.