Closed Bug 1267316 Opened 6 years ago Closed 6 years ago

drag and drop email address incorrectly inserted in TO field

Categories

(Thunderbird :: Message Compose Window, defect)

45 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1267804

People

(Reporter: anjeyelf, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160407164938

Steps to reproduce:

Method 1 was brought to my attention by someone asking for help on the support forum.
I also performed a variety of tests to confirm method 1 nad also discovered method 2 was also causing same issue.

Both of the following methods are producing incorrect results.
Method 1:
Click on Write to open a new Write message.
Click on 'Address Book'
select address book
left click hold down on contact and drag into the 'TO' field of open Write window.

Method 2:
Click on 'Write'
make sure Contacts sidebar is enabled
select address book
left click hold down and drag and drop contact into TO field.



Actual results:

The 'email address' is now incorrectly written, a sort of messed up version of writing it twice, but munged up. I can get various messed up configurations.
The 'Attachments' side section also auto opens as if expecting an attachment.



Expected results:

Method 1 via Address Book
I believe (if wrong I stand corrected) you should not be able to drag and drop the actual Contact display line into a TO field, but instead should select the contact and click on Write.
However, a user has been trying to do this with strange results which I can duplicate.

Method 2 via Write Contacts Sidebar
selected contacts should be able to use drag and drop to insert a contacts email address.

This has been tested in Thunderbird safe Mode with same results.
I cannot reproduce this on windows 7 using version 45

> The 'email address' is now incorrectly written, a sort of messed up version of writing it twice, but munged up. 
> I can get various messed up configurations.
please attach a screen shot to the bug report
Component: Untriaged → Message Compose Window
Flags: needinfo?(anjeyelf)
Also please post URL to the support topic
Support site url:
https://support.mozilla.org/en-US/questions/1119652?
Supplied image showing Write window.
Used drag and drop method from Contacts Sidebar into a TO field.
Doing this the first time will auto open the Attachments pane.

If you open the 'Address Book', select address book to see list of contacts.
Then drag and drop a contact from the list into the opened Write window, the same results can be reproduced.

Using these methods it is reproduceable 100%.
Sorry, forward duplicating this to bug 1267804. There we have the regression range, etc.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(anjeyelf)
Resolution: --- → DUPLICATE
Duplicate of bug: 1267804
You need to log in before you can comment on or make changes to this bug.