Closed Bug 1267582 Opened 8 years ago Closed 3 years ago

No clear message that Netflix videos are not running in Private Browsing mode

Categories

(Core :: Audio/Video: Playback, defect, P5)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
platform-rel --- -
firefox49 --- affected
firefox52 --- affected

People

(Reporter: sbadau, Unassigned)

References

Details

(Whiteboard: [platform-rel-Netflix])

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160425102203

[Note]:
User Agent Switcher add-on is installed and enabled.
Widevine Content Decryption Module provided by Google is installed and enabled.
Primetime Content Decryption Module provided by Adobe Systems is disabled.

[Affected versions]:
Nightly 49.0a1
Aurora 48.0a2


[Affected platforms]:
Windows
Mac OSes

[Steps to reproduce]:
1. Launch Firefox
2. In the Navigation Bar, look for the User Agent Switcher add-on and set Google Chrome as a desktop browser
3. Go to Private Browsing: click on Open menu button and then click on New Private window
4. Login to Netflix
https://www.netflix.com
5. Start playing any video

[Expected result]:
The video should not start and the message the Netflix video is not playing in private browsing should be clear like: "Whoops, something went wrong... Private Browsing Mode error... Please turn off Private Browsing and try again"

[Actual result]:
The video does not start and the message says: 
"Whoops, something went wrong...
Unexpected Error

There was an unexpected error. Please reload the page and try again."

[Regression range]:
Not a regression.
Related to Bug 1255286.
See Also: → 1255286
This problem also affects Adobe Primetime, not just Widevine. Netflix needs IndexedDB, which doesn't work in Private Browsing mode (bug 781982). There is no easy way for Netflix to detect when the user is running in Private Browsing mode (in Firefox), so they don't want to show an error message about Private Browsing.
Depends on: 781982
Priority: -- → P5
Summary: [Widevine] No clear message that Netflix videos are not running in Private browsing → No clear message that Netflix videos are not running in Private Browsing mode
Fix:
About:Config

media.mediasource.enabled

Right click on it.
Set it to false.

Refresh Netflix page with error.
It should start playing.

My info:
Firefox
Version 	47.0
Build ID 	20160604131506

I started to get this error after reimaging my system and installing a fresh copy of Firefox.

All options including on the help page of Netflix failed. It was not a history issue. It was not a cache or db issue.
> It was not a history issue. It was not a cache or db issue.

Then please file a new bug instead of polluting existing bugs.
platform-rel: --- → ?
Whiteboard: [platform-rel-Netflix]
Netflix is aware of this problem. It should be fixed after bug 781982 adds support for IndexedDB in Private Browsing mode.
platform-rel: ? → -
platform-rel: - → +

Posting here as I came across this bug when trying to find a solution to play Netflix in a private window.
Not Firefox nor Netflix provide any help on how to resolve the problem.
(I was on the latest version of Firefox when taking the screenshot - 85)

Markus tried setting dom.indexedDB.privateBrowsing.enabled to true, but that didn't help.

According to https://help.netflix.com/en/node/32661, the error code "F7701-1003" likely indicates a problem with the Widevine CDM. Any reason this should not be working in PB mode?

Tried all steps suggested in Netlfix help page short of not using a private window.
Noticed that previews play any video nicely, but full page player shows these errors:

Uncaught (in promise)
Object { code: 7701, sd: 1003, Pg: undefined, XI: undefined, uu: undefined, 
         message: "Unable to create media keys system access. Key system configuration is not supported", 
         Iw: "Key system configuration is not supported", data: DOMException, yha: undefined, 
         CJb: undefined, … 
       }
XML Parsing Error: not well-formed Location:
 https://www.netflix.com/nq/msl_v1/cadmium/pbo_manifests/%5E1.0.0/router?reqAttempt=1&reqPriority=20&reqName=manifest&clienttype=akira&uiversion=vadb0bb81&browsername=firefox&browserversion=87.0.0&osname=windows&osversion=10.0 
Line Number 1, Column 1:

Bryce, would you mind to take a look at this?
Would we treat thing differently while watching DRM content in a private browsing window?
Thank you.

Flags: needinfo?(bvandyk)

Comment 2 outlines the problem here -- we don't make certain APIs available in private browsing, and Netflix relies on IndexedDB and errors since it's not available. Looking around bug 1639542 seems like it could remedy this. Assuming comment 2 still holds, I don't know if there's much we can do right now on the media side.

Flags: needinfo?(bvandyk)

Looking more at this the issue is that Netflix requests persistentState for their CDM access. We do not allow the CDM to persist state in private mode (bug 1334111). I'm going to close this, but we could reopen this if a design decision is made such that we want to allow persistent state (and then track the work on this bug).

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
See Also: → 1334111
No longer depends on: idb-private-browsing
See Also: → 1706121
Duplicate of this bug: 1706121
No longer duplicate of this bug: 1706121
You need to log in before you can comment on or make changes to this bug.