Closed Bug 1267618 Opened 5 years ago Closed 5 years ago

'Edit as new Message' inserting who it was originally FROM into the FROM.

Categories

(Thunderbird :: Message Compose Window, defect)

45 Branch
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1254666

People

(Reporter: anjeyelf, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160407164938

Steps to reproduce:

This has been reported  as occurring by someone in the Support forum.
https://support.mozilla.org/en-US/questions/1119978

I checked this out and can reproduce the error.
Received email.
Right click on received email and select 'Edit as new message'


Actual results:

The 'FROM' field was populated with the email address of the original sender.
This means I could send emails using someone elses email address.

The TO' field was populated with my email address.

In other words, it is exactly the same as the received message.


Expected results:

I would expect the 'FROM' field to insert my email address as is the norm when composing a new email.

I would expect the TO field to be empty awaiting input.
I should have stated:
FROM, TO, Subject and Content are identical to the received email.
Severity: normal → major
Component: Untriaged → Message Compose Window
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1254666
You need to log in before you can comment on or make changes to this bug.