[DOGFOOD] need rules code for delete selection

VERIFIED FIXED in M12

Status

()

Core
Editor
P1
normal
VERIFIED FIXED
19 years ago
a year ago

People

(Reporter: Akkana Peck, Assigned: Joe Francis)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
Joe writes:
need rules code for delete selection.  If you select an <hr>, delete it, then
hit backspace again, you will delete an entire block of text (assuming there is
some nearby) rather than a single character.  The root of this problem is that
the low level delete code can't be psychic and deduce what kind of elements
should be "stepped into" when you hit backspace, vs what kind of elements should
be deleted outright.  Needed for dogfood.
(Reporter)

Updated

19 years ago
Blocks: 12658
(Reporter)

Comment 1

19 years ago
Adding dogfood dependency.
(Assignee)

Comment 2

19 years ago
accepting bugs; setting to m11
(Assignee)

Comment 3

19 years ago
*** Bug 9576 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Target Milestone: M11 → M12

Comment 4

19 years ago
moved to M12.

Updated

19 years ago
Whiteboard: [PDT+]

Comment 5

19 years ago
Putting on [PDT]+ radar.

Updated

19 years ago
Priority: P3 → P1
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
This has been fixed for a while.  I only left it open to remind myself that we
needed table-specific deletion rules.  But there is a seperate bug on that now:
16481.

Sujay: test case for verifying this bug is to bring up the editor test page,
select the HRule, delete it, then continue deleting and see that the text before
the hrule deletes one character at a time (it used to all delete at once).

Updated

19 years ago
Blocks: 17907

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
verified in 11/4 build.

Updated

18 years ago
No longer blocks: 17907
You need to log in before you can comment on or make changes to this bug.