Context menus have no border (Linux, Gtk3)

RESOLVED WORKSFORME

Status

()

defect
P4
normal
RESOLVED WORKSFORME
3 years ago
9 months ago

People

(Reporter: post+mozilla, Unassigned)

Tracking

(Blocks 2 bugs)

46 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:+)

Attachments

(1 attachment)

Posted image screen.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160421124000

Steps to reproduce:

* Make sure you have a white background, e.g. on the "New Tab" page or on Google
* Open any context-menu, e.g. right-click on a website or open one of the bookmark folders from the bookmark toolbar.


Actual results:

The menu was rendered without any border, so one cannot even tell where the menu ends and the page content begins. I will attach a screenshot demonstrating this.


Expected results:

There should be a border.

This started happening with the update to Firefox 46, i.e., GTK3. Other GTK3 applications have a border just fine; I tried Liferea. I also tried a different GTK3 theme, with the same result -- no border in Firefox' menus.
Blocks: gtk3
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Summary: Context menus have no border → Context menus have no border (Linux, Gtk3)
I have a border with GTK 3.16 and Adwaita.

Which GTK3 version is installed, and which themes have you seen demonstrate this problem?
This is with GTK3 3.18.9 on Debian testing. I tried the Adwaita and HighContrast themes. (For some reason, Xfwm crashes when I change the theme, so I didn't really want to try further ones^^).
Confirmed with black themed Gnome/GTK 3.20 on Archlinux, so having a context menu without any borders around, in black.
This is the case for menus from menubar too.

Screenshot can be joined if needed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → 1267759
Same with OpenSUSE 13.2 and default desktop theme on KDE4 (SeaMonkey, own trunk build).
Priority: -- → P4
Whiteboard: tpi:+
Same with debian stable (jessie) and Firefox 50.
Cannot reproduce with firefox 52 and debian stretch with clearlooks-phenix theme.
Indeed with upstream Firefox 52 on Debian testing, the context menu now looks just fine.
Blocks: SM2.49-GTK3
Do you still see this issue? Thanks.
Flags: needinfo?(post+mozilla)
Seems to be fixed. Thanks!
Flags: needinfo?(post+mozilla)
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Changing resolution to WFM given that neither a patch was produced and checked in here nor another bug referenced which provided the solution. If such a bug exists, please dupe this one to it.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.