Closed Bug 1268182 Opened 3 years ago Closed 3 years ago

Intermittent viewport-change.html | picture: same URL in source (max-width:500px) and img, resize to wide - expected FAIL

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox50 --- fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: KWierso, Assigned: jdm)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

See Also: → 1294705
FWIW, this is basically permafail on Win8 debug e10s.
The intermittancy here is caused by the same problem as bug 1294705. We're always failing this test by dispatching a load event, but sometimes it doesn't get processed before the test decides it's safe to move on.
Component: web-platform-tests → DOM
Product: Testing → Core
Assignee: nobody → josh
Status: NEW → ASSIGNED
Comment on attachment 8792917 [details] [diff] [review]
Allow image loads to short-circuit after selecting a source if the new source URL matches the previous one URL

Lots of reftest failures that need investigation.
Attachment #8792917 - Flags: review?(echen)
Attachment #8792917 - Attachment is obsolete: true
Attachment #8794951 - Flags: review?(echen) → review+
Duplicate of this bug: 1266690
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fc4b39cdfb64
Allow image loads to short-circuit after selecting a source if the new source URL matches the previous one URL. r=echen
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/fc4b39cdfb64
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
OrangeFactor doesn't show any new reports since this got merged around. Please request Aurora/Beta approval on this when you feel it's baked sufficiently long.
Flags: needinfo?(josh)
Depends on: 1307185
Comment on attachment 8794951 [details] [diff] [review]
Allow image loads to short-circuit after selecting a source if the new source URL matches the previous one URL

Approval Request Comment
[Feature/regressing bug #]: Unclear if there was a specific trigger or not.
[User impact if declined]: Unhappy sheriffs.
[Describe test coverage new/current, TreeHerder]: A test stops intermittently passing.
[Risks and why]: Caused one immediate regression (bug 1307185), but none have been found since. Only affects a small edge case for image loading (the same URL multiple times), so the risk is well scoped.
[String/UUID change made/needed]: None
Flags: needinfo?(josh)
Attachment #8794951 - Flags: approval-mozilla-beta?
Attachment #8794951 - Flags: approval-mozilla-aurora?
Comment on attachment 8794951 [details] [diff] [review]
Allow image loads to short-circuit after selecting a source if the new source URL matches the previous one URL

Fixes an intermittent, Aurora51+, Beta50+
Attachment #8794951 - Flags: approval-mozilla-beta?
Attachment #8794951 - Flags: approval-mozilla-beta+
Attachment #8794951 - Flags: approval-mozilla-aurora?
Attachment #8794951 - Flags: approval-mozilla-aurora+
Depends on: 1317901
Depends on: 1318889
Depends on: 1319046
Liz, can we keep an eye on this bug for a possible release 50.x due to its regression bugs? It seems to affect some corporate websites/apps.
Flags: needinfo?(lhenry)
NB: the work about fixing the regression is in bug 1317901.
Yes, thanks Loic! I commented in bug 1317901. Best to nominate there for uplift to mozilla-release and explain why. Ritu is the release manager for 50 so I gave her the heads up in that bug too.
Flags: needinfo?(lhenry)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.