Provide GTK2 channel builds until GTK3 will be mostly bug free

RESOLVED WONTFIX

Status

()

Core
Widget: Gtk
--
major
RESOLVED WONTFIX
2 years ago
3 months ago

People

(Reporter: Carsten Mattner, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

46 Branch
All
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:-)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160420142932

Steps to reproduce:

Look for gtk2 builds.


Actual results:

None found.


Expected results:

gtk2 channel (builds) should be available for at least x86_64 because gtk3 itself and the Firefox integration are unfortunately, as can be seen in the tracking bug, the cause of many major regressions compared to gtk2. This makes Firefox in most cases unusable or look like a semi-finished port to an obscure platform.

Can we please have a gtk2 channel?
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Blocks: 627699, 1186003
Summary: gtk2 channel → Provide GTK2 channel builds until GTK3 will be mostly bug free
Severity: normal → major
Component: Untriaged → Widget: Gtk
Keywords: regression
Product: Firefox → Core
Hardware: x86_64 → All

Comment 1

2 years ago
That will be great. For those using pure GTK+2 based environments (eg., Debian Wheezy with XFCE) Firefox 46 is still usable but UI looks no good as it defaults to Raleigh theme which basically means going back to the 90's.
(Reporter)

Comment 2

2 years ago
Raleigh would be fine if 3.20 didn't break it and you didn't have to port your Raleigh color modification for each GTK3 release and keep one variant for each distro's different GTK3 release. I like Raleigh and have been using a nice GTK2 personal Raleigh theme for years but the GTK3 Raleigh engine is deliberately ugly and not a direct port in order to make it less appealing.
(Reporter)

Comment 3

2 years ago
I vote for a GTK2 channel that's built indefinitely like say for at least the next 4 years until GTK3 hopefully gets stable and regression-free.
(Reporter)

Comment 4

2 years ago
What can we do to make this a reality before the ESR channel also regresses by moving to GTK3?
The graphics changes in bug 1180942 would make gtk2 builds very slow, and so effort would be better spent resolving the issues that make gtk3 builds less appealing.
(Reporter)

Comment 6

2 years ago
That's just the backend, which has been pluggable (configurable) all along.

But more importantly GTK3 just isn't stable for any meaning of the word. The places where GTK3 works reliably and consistently are very limited and are those in the focus of the GNOME project. This is very unfortunate, and in the past I've preferred GTK2 over Qt(3,4).

Take GTK3.20 and try to use a vanilla (no modification), just referenced by name, Raleigh theme via settings.ini and you'll realize that it's broken completely now. Before, it was just a deliberately worse looking port of GTK2 Raleigh, but in order to prevent users from selecting it, it seems to be broken, or hopefully it's just that they don't support it and got broken but unnoticed by the GNOME team. I hope it's the latter.

Either way, GTK3 theme support doesn't really exist, you must do some trickery to share your home directory between GTK3 versions, and the drawing slowdowns and corruptions still exist.

If the idea is that Firefox GTK3 is meant to be used only with select configuration of GTK3 (like under GNOME3 or some other vetted setup), then this should be documented. As it stands, the environments in which Firefox GTK3 looks and behaves at least as correctly as before are very limited.

Updated

2 years ago
Whiteboard: tpi:-
Duplicate of this bug: 1321821

Comment 8

2 years ago
Created attachment 8818852 [details]
firefox45-gtk2-human-clearlooks.png

Here is a screenshot of my beautiful Firefox 45 64 bits on Debian/Linux/Mate 1.12 with Gtk 2.20.2. I haven't a screenshot here with Firefox 50... but it is a disaster.

Please, Please, Please, can you plan Gtk2 builds?
(Reporter)

Comment 9

a year ago
Has GTK2 support been removed permanently with 53? If that's the case this bug seems pointless now.

Close as WONTFIX?

<mini-rant>
GTK3 still is misbehaving in various functional and rendering ways outside a GNOME3 session, but I guess the final solution is removing GTK dependency altogether and fix it for good. Or finally revive the Qt backend for a more compatible toolkit that also doesn't regress as often in basic functionality like GTK3 unfortunately does. I have reported the issues upstream at gnome.org's tracker but any usage of GTK3 outside GNOME3 seems to have infinitely negative priority. Sorry for the rant but GTK3 is the same as Windows 10. It made major architectural improvements while regressing in many usage scenarios. Qt doesn't suffer like this since it has an embedded focus and is more compatible/reasonable.
</mini-rant>

Comment 10

a year ago
So, long live Firefox 45!
(Reporter)

Comment 11

3 months ago
I suppose this can be closed as WONTFIX like I suggested a year ago. Despite GTK3 suffering regressions,
it doesn't look like Firefox GTK2 support will be reenabled. I can't seem to do it myself,
would be cool if someone else could resolve as WONTFIX.

Updated

3 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.