"new/clone bug" menu should use regular <a> to provide consistent/better UX

RESOLVED DUPLICATE of bug 1129933

Status

()

bugzilla.mozilla.org
User Interface: Modal
--
minor
RESOLVED DUPLICATE of bug 1129933
2 years ago
2 years ago

People

(Reporter: MattN, Assigned: dkl)

Tracking

Production

Details

Attachments

(1 attachment)

The markup is currently like so:

> <li class="context-menu-item"><span>Create a new Bug</span></li>

with an event listener on the <li> but it's really annoying that I can't copy the link or use the usual browser controls to affect where/how the page opens.

I think all of the options just end up loading a URL so they should be implemented as regular links (<a>) to get the expected behaviour.
Duplicate of this bug: 1278286
(Assignee)

Updated

2 years ago
Assignee: nobody → dkl
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
Created attachment 8760952 [details] [diff] [review]
1268295_1.patch
Attachment #8760952 - Flags: review?(dylan)
Comment on attachment 8760952 [details] [diff] [review]
1268295_1.patch

as all context menus should behave the same way this should be extended to all context menus (which probably means making it a template that can be included).
Attachment #8760952 - Flags: feedback-
this is almost certainly a dupe of bug 1129933.
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1129933
(Assignee)

Updated

2 years ago
Attachment #8760952 - Flags: review?(dylan)
You need to log in before you can comment on or make changes to this bug.