Add ability to disallow install/uninstall search engines by the user

RESOLVED DUPLICATE of bug 289826

Status

()

defect
RESOLVED DUPLICATE of bug 289826
3 years ago
2 years ago

People

(Reporter: yuki, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 affected)

Details

(Whiteboard: [design-decision-denied]triaged)

Reporter

Description

3 years ago
For enterprise use, available search engines are wanted to be restricted and the administrator hopes to disallow installing of new search engines by users. In current Firefox we can do it by hiding "Add Search Engine" UIs via userChrome.css or something. After XUL is ended, we need something to alter it.
Reporter

Comment 1

3 years ago
This is similar/related to the bug 1268401.

Updated

3 years ago
Whiteboard: [design-decision-needed]triaged
Reporter

Comment 2

3 years ago
A sample plan of the API is here:

chrome.extensions.lock() // disallow to install new addons
chrome.extensions.unlock() // allow to install new addons

This API should require special permissions.
Reporter

Comment 3

3 years ago
Sorry, I wrongly posted different API idea...
The idea for the search engines is:

chrome.searchengines.lock() // disallow to install new engine
chrome.searchengines.unlock() // allow to install new engine

I think the API should control only for installations by the user himself, in other words, installation of search engines from addons (via another API) should be allowed. Or, these method may have an optional parameter to specify the level of restriction: only for users, or anyone (including addons).

This API should require special permissions

Updated

3 years ago
Component: WebExtensions: Untriaged → WebExtensions: General

Comment 4

3 years ago
We don't plan on this API in WebExtensions. Moving over to Firefox to see if that's something that would happen through configuration of other means.
Status: NEW → UNCONFIRMED
Component: WebExtensions: General → General
Ever confirmed: false
Product: Toolkit → Firefox
Whiteboard: [design-decision-needed]triaged → [design-decision-denied]triaged

Updated

3 years ago
Component: General → Search
Removing from webextensions-additional-apis, this belongs in some kind of policy system.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 289826
You need to log in before you can comment on or make changes to this bug.