Print email with event, the event is missing in the print-out

RESOLVED FIXED in 4.7.2

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Bugzilla, Assigned: MakeMyDay)

Tracking

({regression})

Lightning 4.4
4.7.2
Dependency tree / graph

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160421124000

Steps to reproduce:

I print an email with an invitation to an event (TB45 with lightning 4.7). 



Actual results:

In the print-out the event (place, date, participants) is missing, i can only see the header of the email (subject, to, from). 

It works fine with TB 38.7.2 (integrated lightning - i don't know the version)
I can confirm this is not working in 5.1. Based on print preview, no content is printed at all. (On top of this, in 5.1 the css decoration wouldn't work due to bug 1246500, but this wouldn't affect 4.7).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Also confirming not to work in 4.7.

We need a regression range here as this is triggered either by a change in TB or more likely in Toolkit.

It's enough to check the print preview wether all the invitation details are displayed, which is currently not the case.

To create an invitation email if not already available, it is the easiest to create a new event, invite yourself, click the save&close button and confirm sending. After that, you can use either the incoming or outgoing email to check the issue. Make sure the calendar has your email address assocciated for being able to send invitations.
Duplicate of this bug: 1274035
Mike, do you happen to know wether any of the printing changes related to e10n may now prevent printing the overlay to the message Lightning uses display the event data? I don't have a regression range yet, so anything after 38 might be a candidate.
Flags: needinfo?(mconley)
Hm. Nothing comes to mind. We tried to make the PrintUtils API changes as backwards-compatible as possible - thought we may have missed something. :/

Any console errors of note from within printUtils.js, or browser-content.js?
Flags: needinfo?(mconley) → needinfo?(makemyday)
(In reply to MakeMyDay from comment #4)
> Mike, do you happen to know wether any of the printing changes related to
> e10n may now prevent printing the overlay to the message Lightning uses
> display the event data? I don't have a regression range yet, so anything
> after 38 might be a candidate.

Sorry, I don't know what e10n is in relation to.  I install Thunderbird updates when ever I'm informed of one...I don't pay attention to the update number.  I then install the latest version of lightning.
Just to clear things up, e10s is nerd-shortform for "Electrolysis", which is the multiprocess project for Firefox (https://wiki.mozilla.org/Electrolysis). The printing code needed to be changed in order to work properly with the multi-process model - though as I say in comment 5, it's possible our changes were not perfectly backwards compatible for Thunderbird's single-process usage.
Unfortunately there are no messages in the error console. Is there a debug mode for printing? Haven't found a suitable pref.

Lightning relies for printing of the invitation email completely on TB and printing regular emails seems to work flawlessly.

Can this be related to a missed fix for the inner/outerDOMWindow change?
Flags: needinfo?(makemyday)
(In reply to MakeMyDay from comment #8)
> Can this be related to a missed fix for the inner/outerDOMWindow change?

This was missed? Hrm. Was there a toolkit / TB / SM bug for that?
Flags: needinfo?(makemyday)
No it was not missed in general. I just thought whether there might be a missing peace. On the other hand, that should throw errors, which is obviously not the case (although I haven't tested with a debug build).

The core bug was bug 1241764, for CC there were two related bugs: bug 1243760 and bug 1254596.
Flags: needinfo?(makemyday)
Mike, sorry for the noise. After a lengthy regression range detection it turned out this is a Lightning internal regression from bug 533265.
Blocks: 533265
Version: Lightning 4.7 → Lightning 4.4
Assignee: nobody → makemyday
Status: NEW → ASSIGNED
Attachment #8755209 - Flags: review?(philipp)
Attachment #8755209 - Flags: approval-calendar-esr?(philipp)
Attachment #8755209 - Flags: approval-calendar-beta?(philipp)
Attachment #8755209 - Flags: approval-calendar-aurora?(philipp)
Comment on attachment 8755209 [details] [diff] [review]
FixInvitationPrinting-V1.diff

Review of attachment 8755209 [details] [diff] [review]:
-----------------------------------------------------------------

Perfect, thanks for diagnosing this!
Attachment #8755209 - Flags: review?(philipp)
Attachment #8755209 - Flags: review+
Attachment #8755209 - Flags: approval-calendar-esr?(philipp)
Attachment #8755209 - Flags: approval-calendar-esr+
Attachment #8755209 - Flags: approval-calendar-beta?(philipp)
Attachment #8755209 - Flags: approval-calendar-beta+
Attachment #8755209 - Flags: approval-calendar-aurora?(philipp)
Attachment #8755209 - Flags: approval-calendar-aurora+
https://hg.mozilla.org/comm-central/rev/f10c492613ccfe53350c2e8753483ba5723eeb31
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 5.1
Keywords: checkin-needed
Whiteboard: [checkin-needed comm-aurora, comm-beta]
https://hg.mozilla.org/releases/comm-aurora/rev/ee8bca50ea41c3ca07cefea3b7d39ece0700fd22
https://hg.mozilla.org/releases/comm-beta/rev/7a68c141216bd6d3ca7c1b0a5b54b3eec7b89dd5
Whiteboard: [checkin-needed comm-aurora, comm-beta] → [checkin-needed comm-esr45 after 45.1.1 was released]
Target Milestone: 5.1 → 4.9
https://hg.mozilla.org/releases/comm-esr45/rev/7a7aaa5c83c36fa02ba5f01eb78aa41cbf859a58
Keywords: checkin-needed
Whiteboard: [checkin-needed comm-esr45 after 45.1.1 was released]
Target Milestone: 4.9 → 4.7.2
Duplicate of this bug: 1281026
You need to log in before you can comment on or make changes to this bug.