Allow device management from SyncedTabs menu and sidebar context menu

RESOLVED FIXED in Firefox 55

Status

()

P2
normal
RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: markh, Assigned: eoger)

Tracking

(Depends on: 1 bug, {feature})

unspecified
Firefox 55
feature
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 verified)

Details

(Whiteboard: [sync-ui-polish])

Attachments

(2 attachments)

We've discussed this before but I can't find a bug - when a device name is shown in the sidebar or menu, we should offer a way to manage that device. All we need is a way to actually manage the device ;) After we get that, we'll need to ask Ryan for the mockups of how the sidebar/menu UI should look.
Flags: firefox-backlog+
Depends on: 1269278
Device management generally involves three things:
1. Seeing when the device was last synced.
2. Disconnecting the device.
3. Renaming the device.

What do you think about splitting this bug up into a few bugs relating to a tooltip and the contextual menu?

Currently the tooltip just repeats the device name. I'm proposing we replace that with the last sync time. https://bugzilla.mozilla.org/show_bug.cgi?id=1269348&redirect=no

The tooltip currently just says "Sync Now". What does it say when the device is in other states? Probably nothing.

What do you think about a contextual menu on devices that looked like this?

Sync Now
Rename… --> Modal sheet with device name and Rename and Cancel buttons
--------------
Disconnect… --> Disconnect device dialog with Disconnect and Cancel buttons

That way we can ship name and disconnect separately.
Flags: needinfo?(markh)
Created attachment 8747760 [details]
edit-in-line.gif

Safari allows users to rename bookmarks inline. I don't see why we couldn't do something like this too for devices.
Very nice. Would you like to add the inline rename UI to both the sidebar and the panel?
No, just the sidebar, though I will obviously have to provide more detailed design (as I don't think editing in-line is currently possible in the sidebar).
Keywords: feature
No longer depends on bug 1269278 as this is heading towards all UI being client-side.

(In reply to Ryan Feeley [:rfeeley] from comment #1)
> Device management generally involves three things:
> 1. Seeing when the device was last synced.

Bug 1269348 is for that.

> 2. Disconnecting the device.
> 3. Renaming the device.

Long story short, we need FxA device support on mobile for this to work with reasonable UX :( Without local rename, there's arguably not enough motivation to offer "disconnect" - if there is, this should be split into a new bug - Ryan, can you please open one if you would like that before we get rename?

Bug 1254640 and bug 1252117 are the mobile work...
Depends on: 1254640, 1252117
No longer depends on: 1269278
Flags: needinfo?(markh) → needinfo?(rfeeley)
(In reply to Mark Hammond [:markh] from comment #5)
> Ryan, can you please open one if you would like that before we get rename?

fxa-content-server on GitHub or a component on Bugzilla? I'm not sure to whom the bug is addressed.
Flags: needinfo?(rfeeley)
(In reply to Mark Hammond [:markh] from comment #5)
> there's arguably not enough
> motivation to offer "disconnect" - if there is, this should be split into a
> new bug

We actually can't even offer that without additional FxA work that would be somewhat redundant if we fix those other bugs allowing us to rename - ie, it's possible, just maybe not worthwhile. We should probably take this to the product meeting.
Flags: firefox-backlog+

Updated

2 years ago
Summary: Allow device management from SyncedTabs menu and sidebar. → [SYNC-50] Allow device management from SyncedTabs menu and sidebar.

Updated

2 years ago
Summary: [SYNC-50] Allow device management from SyncedTabs menu and sidebar. → [meta][SYNC-50] Allow device management from SyncedTabs menu and sidebar.
Priority: -- → P3
Whiteboard: [sync-ui-polish]
(Assignee)

Comment 8

2 years ago
Should we get back to this now? The prerequisites are met on desktop and Android at least.
The disconnect button is not much work since we now have bug 1339861 landed (we could delete the device then reload the stale list).
For renaming, the APIs are ready too.
Priority: P3 → --
Summary: [meta][SYNC-50] Allow device management from SyncedTabs menu and sidebar. → Allow device management from SyncedTabs menu and sidebar.
(Assignee)

Comment 9

2 years ago
Ryan, what do you think of redirecting users to the FxA settings page with the modal window open when we click on "Disconnect"?
Flags: needinfo?(rfeeley)
Priority: -- → P2
(Assignee)

Comment 10

2 years ago
Todo: bug rfeeley in person
Assignee: nobody → eoger
Status: NEW → ASSIGNED
In the sidebar, if the user right-clicks on a device name, we can add a "Manage Devices…" option which would link to this page for that specific user: https://accounts.firefox.com/settings/clients

"Manage Devices…" would appear above "Sync Now".

We would at the same time, also offer the same "Manage Devices…" option in the Synced Tabs menu above "Sync Now".
Flags: needinfo?(rfeeley)
Comment hidden (mozreview-request)
(Reporter)

Comment 13

2 years ago
mozreview-review
Comment on attachment 8845624 [details]
Bug 1269277 - Add Manage Device button in Synced Tabs menu/sidebar.

https://reviewboard.mozilla.org/r/118756/#review120880

Looks great - please make sure rfeely gives it a thumbsup!
Attachment #8845624 - Flags: review?(markh) → review+
Comment hidden (mozreview-request)

Comment 15

2 years ago
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/805da5d5567f
Add Manage Device button in Synced Tabs menu/sidebar. r=markh
Comment hidden (mozreview-request)
(Assignee)

Comment 18

2 years ago
Sorry about that, looks like I forgot to run the mochitests
Flags: needinfo?(eoger)

Comment 19

2 years ago
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cfe8ab5f1c08
Add Manage Device button in Synced Tabs menu/sidebar. r=markh
Comment hidden (mozreview-request)
(Assignee)

Comment 22

2 years ago
Try looks okay now, landing.
Flags: needinfo?(eoger)

Comment 23

2 years ago
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8ffb5d661b03
Add Manage Device button in Synced Tabs menu/sidebar. r=markh

Comment 24

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8ffb5d661b03
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55

Updated

2 years ago
Summary: Allow device management from SyncedTabs menu and sidebar. → Allow device management from SyncedTabs menu and sidebar context menu

Updated

2 years ago
QA Contact: mihai.ninu
Verified as fixed on latest Nightly build. Tested on Windows 7(64)with Samsung Galaxy S6 Edge (Android 6.0.1), iPhone 6s (fw 10.2.1).
status-firefox55: fixed → verified
Do you plan to have a mention in release notes for this feature? Thanks
Flags: needinfo?(markh)
(In reply to Pascal Chevrel:pascalc from comment #26)
> Do you plan to have a mention in release notes for this feature? Thanks

What do you think Alex?
Flags: needinfo?(markh) → needinfo?(adavis)
(In reply to Mark Hammond [:markh] from comment #27)
> (In reply to Pascal Chevrel:pascalc from comment #26)
> > Do you plan to have a mention in release notes for this feature? Thanks
> 
> What do you think Alex?

Personally, I don't think it is worth it. The release notes are long enough, and this is a feature that will be quite obvious to users of the sidebar or syncedtabs menu. But let's wait to see what Alex thinks.
I don't think it is needed. This is not a major change. The feature already exists. We're just making it easier to find.
Flags: needinfo?(adavis)
Duplicate of this bug: 1250510
You need to log in before you can comment on or make changes to this bug.