Closed Bug 1269421 Opened 4 years ago Closed 3 years ago

HTML tooltips don't work in browser action's pop-up

Categories

(WebExtensions :: Frontend, defect, P3)

defect

Tracking

(firefox49 wontfix, firefox50 affected, firefox51 affected, firefox52 verified)

VERIFIED FIXED
mozilla52
Tracking Status
firefox49 --- wontfix
firefox50 --- affected
firefox51 --- affected
firefox52 --- verified

People

(Reporter: gaubugzilla, Assigned: Tomislav)

References

Details

(Whiteboard: triaged)

Attachments

(2 files)

Attached file Minimal test extension
Steps to reproduce:

1. Download attached extension.
2. Go to about:config and set xpinstall.signatures.required to false.
3. Open Add-ons Manager and install the extension from file.
4. Click the extension's icon in the toolbar (generic puzzle icon).
5. Put the mouse pointer over the panel text and wait.

Expected results:

A tooltip appears (the element has a title attribute).

Actual results:

No tooltip appears. This is the WebExtensions version of bug 918600, and from the look of it the cause is the same (see bug 918600 comment 8).
Priority: -- → P3
Whiteboard: triaged
Assignee: nobody → tomica
Status: NEW → ASSIGNED
Component: WebExtensions: Untriaged → WebExtensions: Frontend
This is trivial, there is no real logic in this change to test.

Built and confirmed the fix manually.
Comment on attachment 8793592 [details]
bug 1269421 - enable HTML tooltips in extension popups,

https://reviewboard.mozilla.org/r/80306/#review79172

thanks!
Attachment #8793592 - Flags: review?(aswan) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5da51b708f74
enable HTML tooltips in extension popups, r=aswan
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5da51b708f74
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
I can reproduce this issue on Firefox 51.0a1 (20160908030434).

This issue is verified as fixed on Firefox 52.0a1 (20160925030226) under Windows 7 64-bit, the tooltip is displayed after I hover over the text panel from the WebExtension icon.
Here is a video for this issue: https://www.dropbox.com/s/id3peigc5790v79/Tooltip.gif?dl=0
Status: RESOLVED → VERIFIED
Thanks for the fix, Tomislav--I've added this to our recognition page: https://wiki.mozilla.org/Add-ons/Contribute/Recognition#September_2016
Wontfix for 49, marking 50-51 as affected.
Duplicate of this bug: 1341121
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.