Allow opening a comment box (and issue) for the commit description

RESOLVED DUPLICATE of bug 1248008

Status

MozReview
Review Board: User Interface
--
enhancement
RESOLVED DUPLICATE of bug 1248008
2 years ago
2 years ago

People

(Reporter: gerald, Unassigned)

Tracking

Production

Details

(Reporter)

Description

2 years ago
Usually I read the commit description first, before looking at the code.
While reading the description, if I see something wrong (e.g., typo, insufficient details, etc.), I make a mental note so that I can write about it in the review header (just before publishing).
But very often, as the code review may take a while, I just forget about the description issue, and it goes unpunished!

So it would be great if it was possible to add a description-related comment right from the diff page, so I can do it at the moment I see an issue.

For bonus points, I would like to select part of the description, and it will be inserted as a quote in the comment box.
(Reporter)

Comment 1

2 years ago
As part of being able to comment on the commit description, it should be possible to open a related issue (to make it more obvious when something needs fixing before landing).
Summary: Allow opening a comment box for the commit description → Allow opening a comment box (and issue) for the commit description
(Reporter)

Comment 2

2 years ago
The more I think about it, the commit description should ideally be treated like a file:
Instead of appearing above files, it would have its own block (as it it was the first file in the patch) where comments&issues can be posted.
It would first look like a new file (no "before" view), but then it would be possible to see diffs between versions of the patch later on.

Comment 3

2 years ago
In fact we are working on exactly what you say in comment 2 right now. :)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1248008
(Reporter)

Comment 4

2 years ago
Squee!

So thank. Much happy.
You need to log in before you can comment on or make changes to this bug.