Closed Bug 1270848 Opened 3 years ago Closed 3 years ago

Back and Forward buttons unavailable

Categories

(SeaMonkey :: Location Bar, defect, P3)

defect

Tracking

(seamonkey2.46 affected)

RESOLVED WORKSFORME
Tracking Status
seamonkey2.46 --- affected

People

(Reporter: quicksilver8, Unassigned)

References

Details

(Whiteboard: [workaround see comment #2])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46a1
Build ID: 20160506003002

Steps to reproduce:

After the (finally!) new today trunk nightly build, buttons Back and Forward, on the left of location bar, are dimmed, and therefore unavailable. Also, namesake menu items from Go menu are dimmed.
OS: Unspecified → Mac OS X
Priority: -- → P3
Hardware: Unspecified → Other
I can confirm this on a home-built SeaMonkey 2.46 under Windows 7 and 8.1 too.
OS: Mac OS X → All
Hardware: Other → All
User agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46a1
Build identifier: 20160606003002
http://hg.mozilla.org/mozilla-central/rev/3e8ee3599a67edd971770af4982ad4b0fe77f073
http://hg.mozilla.org/comm-central/rev/9c6b3837eb83

Back/Forward usually do nothing on remote (not file:///something) URLs.

Workaround: Use the list found under the last separator in the Go menu.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [workaround see comment #2]
Back and Forward buttons, and namesake menu items, have always worked fine on previous versions, also builds. Otherwise, why they should be present? Problem is on latest build. Also, another problem with latest trunk: URL on bar location doesn't match the actual location you go. I.e. after the starting page, if you change, browser go to new URL, but URL name in bar location doesn't change. Latest trunk is some buggy...
(In reply to Rocco Stilo from comment #3)
> Back and Forward buttons, and namesake menu items, have always worked fine
> on previous versions, also builds. Otherwise, why they should be present?
> Problem is on latest build. Also, another problem with latest trunk: URL on
> bar location doesn't match the actual location you go. I.e. after the
> starting page, if you change, browser go to new URL, but URL name in bar
> location doesn't change. Latest trunk is some buggy...

I agree. And, remember, a "workaround" is not a "fix".
See Also: → 1279775
The "back and forward" buttons seemm to be fixed. (The URL bar problem is investigated in bug 1272401.)
Rocco (reporter): Do you still see this bug in the latest SeaMonkey 2.48a1?
Flags: needinfo?(quicksilver8)
Version: SeaMonkey 2.46 Branch → Trunk
(In reply to Tony Mechelynck [:tonymec] from comment #6)
> Rocco (reporter): Do you still see this bug in the latest SeaMonkey 2.48a1?

I can't see a 2.48a1 version available for Mac. In this directory: http://ftp.mozilla.org/pub/seamonkey/nightly/latest-comm-central-trunk/
the latest trunk is always 2.47a1 (6 june). When and where has been uploaded a SeaMonkey 2.48a1 version for Mac?
Our Mac build servers seem to have some problems.

You can try this 2.46 tinderbox build to verify if the problem is fixed:
https://archive.mozilla.org/pub/seamonkey/tinderbox-builds/comm-beta-macosx64/1470411187/
Tinderbox building 2.46 seems to have fixed the problem.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(quicksilver8)
You need to log in before you can comment on or make changes to this bug.