Secure Connection Failed, The connection to the server was reset while the page was loading.

RESOLVED DUPLICATE of bug 1269055

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1269055
2 years ago
2 years ago

People

(Reporter: what2use, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

189 bytes, text/html
Details
(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

1) goto my webhost webmail at https://sheep.arvixe.com:2096/
2) login
3) click on webmail icon
4) Error listed below
5) Click on "Try Again" and able to login


Actual results:

Secure Connection Failed

The connection to the server was reset while the page was loading.

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.


Expected results:

Login should have proceeded without any error

Comment 1

2 years ago
Did it use to work with FF45?

If yes, could you provide a guest account to test, please. (or send login by email if it's not public)
Flags: needinfo?(what2use)
(Reporter)

Comment 2

2 years ago
Yes, it worked fine on firefox 4.5

I created a test account
name is test@tonyvr4.com
and the other login field is my email before the @

Comment 3

2 years ago
could you send me the password by email, please. It doesnt work.
(Reporter)

Comment 4

2 years ago
it is what2use

Comment 5

2 years ago
Ty. I tested with the webmail client Roundcube and I'm able to reproduce. I tried Horde, I wasn't able.
(Reporter)

Comment 6

2 years ago
Sorry I forgot to mention that it does it all the time with roundcube and only occasioally on hoarde and not at all on squirrelmail

Comment 7

2 years ago
I am going to find a regression range by testing with Roundcube (because it's 100% reproducible with various builds of Firefox).
(Reporter)

Comment 8

2 years ago
Thanks, I appreciate the help and await the result of testing

Comment 9

2 years ago
I am randomly seeing the same type of scenario when working on backends of CMS such as WordPress:

******************

The connection was reset

The connection to the server was reset while the page was loading.

The site could be temporarily unavailable or too busy. Try again in a few moments.

If you are unable to load any pages, check your computer's network connection.

If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.


******************

Unfortunately no ways to reproduce as it has been completely random.

Simply reloading the page solves the problem.
(Reporter)

Comment 10

2 years ago
The problem I mentioned is not random and occurs every time.  My computer is not on a firewall

It is not a temporary site glitch as it has been occurring for weeks now and my webhost support can access the webmail without any issue from multiple sites.  I am not sure what version of firefox they are using but my webhost support has tried firefox and chrome.

Also, I have tried two different computers running Firefox and the error is exactly as mentioned.  However, all three computers here work fine with Internet Explorer.  The error is only in Firefox

Comment 11

2 years ago
I tried to find a regression but I got 2 different ranges (and completely illogical), so I think it's not 100% reproducible when cliking the Roundcube webmail, and I hit some false positives during narrowing down the regression.
(Reporter)

Comment 12

2 years ago
So what is the next step to finding a solution?
Firefox is awesome but I need to get my webmail.

Comment 13

2 years ago
I can reproduce this by loading HTTPS page, waiting 5 minutes and submitting the form. The problem appeared with Nginx 1.10 and it works fine with Nginx 1.9.2. Our admins found it works fine with Nginx 1.10 and Firefox 47 b3.

Comment 14

2 years ago
(In reply to Ondrej Brablc from comment #13)
> I can reproduce this by loading HTTPS page, waiting 5 minutes and submitting
> the form. The problem appeared with Nginx 1.10 and it works fine with Nginx
> 1.9.2. Our admins found it works fine with Nginx 1.10 and Firefox 47 b3.

Sorry, it was 1.9.12 which was found to be working.

Comment 15

2 years ago
I can reproduce this by send a form to Dropbox. Here is a simple example written by html. Every first time open this html by firefox 46, it can hit this problem. 

<html>
<head>
</head>
<body>
<form name="myform" method="post" action="https://www.dropbox.com">
</form>
<script type="text/JavaScript">
document.myform.submit();
</script>
</body>
(Reporter)

Comment 16

2 years ago
The tech support for My webhost still has no clue.  After weeks and numerous emails, they still can not explain the issue.  Screen captures and listing of steps to reproduce problem have been fruitless.

I hope Mozilla can come up with a solution

Comment 17

2 years ago
I can reproduce this issue also when trying to open the URL http(s)://www.hs-owl.de/onlinebewerbung. Every second or third access leads to a reset. 
Using Wireshark I can see the POST command from the browser an the ACK coming from the Server immediately afterwards the Server sends a [RST, ACK] without any RST coming from the Client:

103	4.082922000	2001:638:505:200::214	2001:638:505:101::babe	HTTP	987	POST /onlinebewerbung/rds?state=wimma&stg=f&imma=anga HTTP/1.1  (application/x-www-form-urlencoded)

104	4.083319000	2001:638:505:101::babe	2001:638:505:200::214	TCP	86	http > 42975 [ACK] Seq=16681 Ack=2556 Win=6875 Len=0 TSval=2674498885 TSecr=110072055

105	4.083331000	2001:638:505:101::babe	2001:638:505:200::214	TCP	74	http > 42975 [RST, ACK] Seq=16681 Ack=2556 Win=6875 Len=0


Watching the same in the JConsole I only see this:

TypeError: this._recipeManager is null LoginManagerParent.jsm:77:9
POST http://www.hs-owl.de/onlinebewerbung/rds [0ms]

This only happens using Firefox Version 46 or 46.0.1 as well in Linux as in Windows.
Using Chrome, IE or a Firefox Version 45 does not show the issue at all.

Best regards

Burkhard

Comment 18

2 years ago
I also saw a similar Bug in https://bugzilla.mozilla.org/show_bug.cgi?id=1169622, but concerning Firefox version 38
(Reporter)

Comment 19

2 years ago
I have done some more testing on my old netbook and it had Firefox 42.0 on it.  The error did not occur.  

I upgraded to Firefox 43.0.1 and the bug did not occur.

As soon as I upgraded to Firefox 46.0.1 the problem occurred and was 100% reproducible.  

Testing steps
1) Firefox 42.0 - problem not occurring
2) Firefox 43.0.1 - problem not occurring
3) Firefox 46.0.1 - PROBLEM OCCURS

I have tested three different pc's and all exhibit the problem as soon as Firefox 46 is installed
(Reporter)

Comment 20

2 years ago
I did a little more testing and found out that the problem does not occur on Firefox 45.0.2
I have confirmed this on multiple pc's and it 100$ reproducible in each case

The problem occurs in Firefox 46.0 and 46.0.1 (Current version as of this writing)

I will stay with 45.0.2 until I hear that this problem is resolved.  After weeks, I can finally access my webmail again

Comment 21

2 years ago
Created attachment 8752222 [details]
dropbox.html

Comment 22

2 years ago
I tested the testcase provided in comment #15 and I can confirm it's fixed in 47+ by bug 1269055.
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ff82b00b481ed96257bd93ce3e28e882a2f292b6&tochange=aef562eaad80d8c5bc4b1ba97c653e71593c6b79

About the reporter's testcase, I can't verify because the webmail guest account has been disabled, so you have to test yourself by downloading Beta: https://www.mozilla.org/en-US/firefox/beta/all/

Comment 23

2 years ago
But I'm confident this bug is just another dupe of bug 1269055.
(Reporter)

Comment 24

2 years ago
Sorry about that.  I forgot to tell my webhost support to leave the account when they tested the other day.  I will put the account back and see what happens.

When is the official version of 47 going to be released?

Comment 26

2 years ago
Pretty sur it's a dupe of bug 1269055 which is fixed in 47+. Reopen it if it's still here after the release of 47 in June.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(what2use)
Resolution: --- → DUPLICATE
Duplicate of bug: 1269055

Comment 27

2 years ago
version 47.0.1 x64, giving Secure Connection failed in Youtube, and basically makes it impossible to downlaod anything (download failed after each few MB). For me, this browser is now unusable.
(In reply to dageezaandroid from comment #27)
> version 47.0.1 x64, giving Secure Connection failed in Youtube, and
> basically makes it impossible to downlaod anything (download failed after
> each few MB). For me, this browser is now unusable.

Hello dageezaandroid,

It's possible that a piece of software on your machine (with or without your consent) is attempting to inject itself into the connection between you and YouTube, and Firefox is interpreting that as a violation of a secure connection.

Please try the steps in this document: https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message
You need to log in before you can comment on or make changes to this bug.