Measure the number of windows opened per "session fragment"

RESOLVED DUPLICATE of bug 1271304

Status

()

P1
normal
RESOLVED DUPLICATE of bug 1271304
3 years ago
2 years ago

People

(Reporter: Dexter, Assigned: Dexter)

Tracking

Trunk
Points:
3

Firefox Tracking Flags

(firefox49 affected)

Details

(Whiteboard: [measurement:client])

(Assignee)

Description

3 years ago
This is about implementing the count of all windows opened in a session fragment.

Can be based on FX_NEW_WINDOW_MS: https://dxr.mozilla.org/mozilla-central/rev/e5a10bc7dac4ee2453d8319165c1f6578203eac7/browser/base/content/browser.js#3871

Independent window chrome counts as a window; full screen video should not be counted.

Context: https://docs.google.com/spreadsheets/d/1G33YEBL2-hSaF0-HrHPi0HVwANoTpYHsnevmMd1eZ1U/edit#gid=0
(Assignee)

Updated

3 years ago
Blocks: 1252625
Priority: -- → P3
Whiteboard: [measurement:client]
(Assignee)

Updated

3 years ago
Assignee: nobody → alessio.placitelli
(Assignee)

Updated

3 years ago
Priority: P3 → P1
Would we need to exclude window open events that were not opened by user actions, say popups?
Or is that negligible for the questions being asked here?
Flags: needinfo?(bcolloran)

Comment 2

2 years ago
Hmmm, I don't have strong feelings on this. I guess exclude them? Rebecca, do you have any thoughts?
Flags: needinfo?(bcolloran) → needinfo?(rweiss)
(Assignee)

Comment 3

2 years ago
Temporarily dropping this and bug 1271304 to add scalar type support (which would be used for the browser engagement measurements).
Assignee: alessio.placitelli → nobody
Priority: P1 → P2

Comment 4

2 years ago
If we can count them separately, that could eventually be useful, but if we can only choose one I'd rather we focused on those measures that we can confidently assert came from deliberate user action.
Flags: needinfo?(rweiss)
(Assignee)

Updated

2 years ago
Priority: P2 → P1
(Assignee)

Comment 5

2 years ago
Sorry for flagging you both, but I'm not sure who should answer.

Do we want to include the number of private windows opened in this count? (ditto for the number of tabs opened).
Flags: needinfo?(rweiss)
Flags: needinfo?(bcolloran)
(Assignee)

Comment 6

2 years ago
(In reply to Alessio Placitelli [:Dexter] from comment #5)
> Sorry for flagging you both, but I'm not sure who should answer.
> 
> Do we want to include the number of private windows opened in this count?
> (ditto for the number of tabs opened).

My gut feeling is that we really shouldn't. We're not doing that for the domain/URI count.
(Assignee)

Updated

2 years ago
Assignee: nobody → alessio.placitelli
Points: --- → 3
(In reply to Alessio Placitelli [:Dexter] from comment #6)
> (In reply to Alessio Placitelli [:Dexter] from comment #5)
> > Sorry for flagging you both, but I'm not sure who should answer.
> > 
> > Do we want to include the number of private windows opened in this count?
> > (ditto for the number of tabs opened).
> 
> My gut feeling is that we really shouldn't. We're not doing that for the
> domain/URI count.

I think we probably need to include this. If we want to answers questions related to window usage etc. we should count all windows.
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1271304
(Assignee)

Comment 9

2 years ago
Moving the ni to bug 1271304.
Flags: needinfo?(rweiss)
Flags: needinfo?(bcolloran)
You need to log in before you can comment on or make changes to this bug.