Port Bug 1223728 to "Import Link" dialog

RESOLVED FIXED in Thunderbird 49.0

Status

MailNews Core
Composition
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

({regression})

unspecified
Thunderbird 49.0
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
Bug 1223728 changed the autocompletesearch="history" to autocompletesearch="unifiedcomplete". Without this change, the hrefInput won't show autocomplete results.
(Assignee)

Comment 1

2 years ago
Created attachment 8750909 [details] [diff] [review]
urllink.patch

Implement autocompletesearch="unifiedcomplete" on hrefInput in "Insert Link" dialog.

I also added the class padded to hrefInput to make it as tall as the other input fields (this is only visible on Winows. Linux and OS X are not affected because padding changes have no effect on -moz-appearance="textbox").

Sorry about the many whitespace fixes.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8750909 - Flags: review?(mkmelin+mozilla)

Comment 2

2 years ago
(In reply to Richard Marti (:Paenglab) from comment #1)
> I also added the class padded to hrefInput to make it as tall as the other
> input fields
Great. It has always looked terrible.

> Sorry about the many whitespace fixes.
I think they're good ;-)

Comment 3

2 years ago
Comment on attachment 8750909 [details] [diff] [review]
urllink.patch

Review of attachment 8750909 [details] [diff] [review]:
-----------------------------------------------------------------

So the only change here is:
-  autocompletesearch="history" timeout="50" maxrows="6"
-  enablehistory="true" class="uri-element"
+  autocompletesearch="unifiedcomplete" timeout="50" maxrows="6"
+  enablehistory="true" class="uri-element padded"

I tested that without the patch there are no auto-complete results, with the patch, there are.

I also checked that this is the correct fix according to bug 1223728, for example:
https://hg.mozilla.org/mozilla-central/rev/44a989cf6c16#l1.13

So: r=jorgk

(Stealing this review since Magnus has a heap of other reviews to get through.)
Attachment #8750909 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 4

2 years ago
Created attachment 8753943 [details] [diff] [review]
urllink.patch

Fixed in comment the reviewer.
Attachment #8750909 - Attachment is obsolete: true
Attachment #8753943 - Flags: review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 5

2 years ago
https://hg.mozilla.org/comm-central/rev/cf9529c1f245
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 49.0
You need to log in before you can comment on or make changes to this bug.