Closed Bug 1272216 Opened 3 years ago Closed 3 years ago

Enable eslint 'quotes' rule requiring double-quotes by default for the entire tree

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1331661
Tracking Status
firefox49 --- affected

People

(Reporter: MattN, Unassigned, Mentored)

References

()

Details

Per https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Coding_Style#Literals

> Double-quoted strings (e.g. "foo") are preferred to single-quoted strings (e.g. 'foo') in JavaScript, except to avoid escaping of embedded double quotes or when assigning inline event handlers.

We should enforce this with eslint's quotes rule with exception for directories (e.g. /accessible/) which don't follow this.

See http://eslint.org/docs/rules/quotes
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1331661
You need to log in before you can comment on or make changes to this bug.