Closed Bug 1331661 Opened 4 years ago Closed 4 years ago

Enable the quotes rule for eslint

Categories

(Toolkit :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: jaws, Assigned: jaws)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

This rule will "enforce the consistent use of either backticks, double, or single quotes (quotes)"

We will use the following configuration:
"quotes": ["error", "double", { "avoidEscape": true, "allowTemplateLiterals": true }],
Comment on attachment 8827508 [details]
Bug 1331661 - Manually fix the remaining 'quotes' errors for eslint.

https://reviewboard.mozilla.org/r/105174/#review105986
Attachment #8827508 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 8827507 [details]
Bug 1331661 - Enable the 'quotes' rule for eslint and fix most of the errors with --fix.

https://reviewboard.mozilla.org/r/105172/#review105988

r=me on the eslintrc change. I'll assume that for something as boring as this, --fix has done the right thing, iff try is happy.
Attachment #8827507 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8cb53491dd1c
Enable the 'quotes' rule for eslint and fix most of the errors with --fix. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/4900b6c465ca
Manually fix the remaining 'quotes' errors for eslint. r=Gijs
Duplicate of this bug: 1272216
https://hg.mozilla.org/mozilla-central/rev/8cb53491dd1c
https://hg.mozilla.org/mozilla-central/rev/4900b6c465ca
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Blocks: 1330063
You need to log in before you can comment on or make changes to this bug.