Improve bugzilla object performance by using Class::XSAccessor for object accessors

REOPENED
Assigned to

Status

()

P2
enhancement
REOPENED
3 years ago
16 days ago

People

(Reporter: dylan, Assigned: me, Mentored)

Tracking

(Blocks: 1 bug)

Production
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

Attachments

(2 attachments, 1 obsolete attachment)

Posted file moo-vs-manual.pl (obsolete) —
Class::XSAccessor accessors provided via Moo are up to 500% faster than manual accessors used currently.
This would have the biggest gain for ->name and ->id which are called in some cases thousands of times.

attached is a benchmark script.
(Reporter)

Comment 1

3 years ago
Posted file moo-vs-manual.pl
revised: 200% faster, there was a mistake in the previous benchmark. Still a nice to have.
Attachment #8753199 - Attachment is obsolete: true
(Reporter)

Updated

3 years ago
Attachment #8753206 - Attachment mime type: application/x-perl → text/plain
(Reporter)

Updated

3 years ago
Keywords: good-first-bug
Whiteboard: [good first bug]
(Reporter)

Updated

3 years ago
Assignee: dylan → general
Mentor: dylan
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623874
(Reporter)

Updated

a year ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

a year ago
Summary: Improve bugzilla object performance by using Class::XSAccessor and/or Moo for object accessors → Improve bugzilla object performance by using Class::XSAccessor for object accessors
(Reporter)

Updated

a year ago
Blocks: 1351895
(Reporter)

Updated

a year ago
Assignee: general → nobody
Component: Bugzilla-General → General
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: 5.1 → Production

Comment 3

a year ago
Hi, can I take this bug?

Comment 4

a year ago
Please provide some guidance on how to go about it
(Reporter)

Comment 5

a year ago
Sorry, someone else has already been working on this.
(Reporter)

Updated

a year ago
Assignee: nobody → me
(Reporter)

Comment 6

a year ago
Posted file PR
Attachment #8955956 - Flags: review+
(Reporter)

Updated

a year ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years agoa year ago
Resolution: --- → FIXED
(Reporter)

Updated

a year ago
Blocks: 1443670
(Reporter)

Comment 7

a year ago
Whoopsy, I failed to completely test this and as a result bug 1443670 happened. I've reverted ed53ecda0546d6c639fa3d227a59ace4d57b81a5.

I'll need to add tests for tracking flags, I realize.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Removing good-first-bug keyword because team does not have bandwidth to mentor at the moment.

Keywords: good-first-bug
You need to log in before you can comment on or make changes to this bug.