Closed Bug 1273515 Opened 6 years ago Closed 5 years ago

Middle mouse click on internal settings links does nothing instead of behaving like left mouse click

Categories

(Firefox :: Preferences, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1120967

People

(Reporter: nachtigall, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:48.0) Gecko/20100101 /
Build ID: 20160516004009

Steps to reproduce:

Followup of https://bugzilla.mozilla.org/show_bug.cgi?id=1268943#c21

Internal links are not middle mouse clickable. That is, things like 
* "Add more search engines" (new tab) 
* "manage your Do Not Track settings" (popup)
* "clear your recent history"  (popup)
* "remove individual cookies" (popup)

I am not sure about the Tabs under "Advanced" like "General", "Data Choices", etc. and buttons like "Choose", "Exceptions", etc. 

Probably easiest if these would handle a middle mouse click just the same as left mouse click.




Actual results:

Middle mouse click does nothing


Expected results:

These should also just open in new tabs or if this in inappropriate, e.g. if it opens a popup, then at least do act the same like left mouse click. For a user it is just strange, that middle mouse click does just nothing. At least please make this work like middle mouse click on the left side tabs like "General", "Search", "Content",... which just work.
See Also: → 1268943
See Also: → 1273517
Reproduced on Mac OS X 10.10, Windows 10 and Ubuntu 15.04.
Status: UNCONFIRMED → NEW
Component: Untriaged → Preferences
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Version: 48 Branch → Trunk
See Also: → 1278842
Bug 1120967 is a duplicate of this bug but was filed first and has a patch so I'll close this one as a dupe. Thanks for filing the bug anyways, better to have a duplicate than no bug at all :)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120967
You need to log in before you can comment on or make changes to this bug.