Closed Bug 1273843 Opened 4 years ago Closed 3 years ago

Unskip test_about_private_browsing.py for e10s mode

Categories

(Testing :: Firefox UI Tests, defect)

49 Branch
defect
Not set

Tracking

(e10s+, firefox49 fixed)

RESOLVED FIXED
mozilla49
Tracking Status
e10s + ---
firefox49 --- fixed

People

(Reporter: whimboo, Assigned: jakehm)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

The test test_about_private_browsing.py got disabled for e10s with the landing of the patch on bug 1122187. At this time it was failing, and which doesn't seem to be the cause anymore. So lets get the test unskipped.
Jacob, would you be interested in this bug?

What needs to be done is simple. Check that you can run our tests via `mach firefox-ui-functional`, then get the test unskipped, and test again if the test gets executed.


https://dxr.mozilla.org/mozilla-central/source/testing/firefox-ui/tests/functional/private_browsing/test_about_private_browsing.py
Assignee: nobody → hskupin
Flags: needinfo?(jacob.harrowmortelliti)
Summary: Unskip → Unskip test_about_private_browsing.py for e10s mode
Yes, please assign me to this bug.  It looks very easy at first glance.
Delete the import:
>from marionette.marionette_test import skip_if_e10s
Delete the decorator:
>@skip_if_e10s
Flags: needinfo?(jacob.harrowmortelliti) → needinfo?(hskupin)
That sounds correct. Also do not miss to test the changes.

Have you worked with mozreview yet? It's the preferred way of uploading patches. If not please read https://mozilla-version-control-tools.readthedocs.io/en/latest/mozreview-user.html.

Thanks.
Assignee: hskupin → jacob.harrowmortelliti
Status: NEW → ASSIGNED
Flags: needinfo?(hskupin)
Blocks: e10s-tests
tracking-e10s: --- → +
Did I do reviewboard right?  I added you as a reviewer.
I'm not sure how reviewboard integrates with this page.
Flags: needinfo?(hskupin)
As mentioned on the other bug you uploaded the patch to the wrong one. Please fix the bug number in the commit message and re-post it.
Flags: needinfo?(hskupin)
Aww shoot I forgot to test.
Uh oh. 'mach firefox-ui-functional' isn't working before or after the patch.

This is my error: http://sprunge.us/GBAh.
Kinda hard to follow what is going on.
Flags: needinfo?(hskupin)
OK I clobbered and rebuilt and my tests are still failing, but differently, so ignore that last bit please.

It seems I don't have mozilla-central/obj-x86_64-pc-linux-gnu/build/automation.py.

Could this be because arch-linux is set up to run python 3 rather than 2?
When I run 
$ ./mach xpcshell-test services/common/tests/unit/

I get:
http://sprunge.us/LAVF
Sorry ignore all that.  I couldn't build due to some unrelated bug that is fixed in the next release.

So I do firefox-ui-functional without any patches imported, and I'm getting 1 failed:

Summary:
https://pastebin.mozilla.org/8872621

Output:
http://sprunge.us/YMjc
Hi Jacob, great to see that you were able to sort out most of the issues over the weekend yourself!  Just a note for the future, you do not have to put a needinfo? request on me each time. I'm always reading my mentored bugs. :)

(In reply to Jacob Mortelliti[:earlgreyhot] from comment #11)
> http://sprunge.us/YMjc

Looks like there are process aborts (crashes?) while you run this specific places test. Did you use Firefox as built from the source or another version? But regarding this patch the failure looks unrelated. I will push the patch to try so that we can see the result.
Flags: needinfo?(hskupin)
This firefox was built from the source.  The only difference from m-c is that I imported 2 patches that fixed an issue for arch linux's version of gcc.
Results of the try build can be found here:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=6b4a0dd1795d&filter-tier=1&filter-tier=2&filter-tier=3

That all looks fine. Going to approve the patch now and mark for landing.

Jacob, thank you for working on it! As a follow-up you may have interest for bug 1274167? Please let me know.
Comment on attachment 8754756 [details]
MozReview Request: Bug 1273843: Unskip test_about_private browsing.py for e10s mode. r=whimboo.

https://reviewboard.mozilla.org/r/54224/#review51204

Nothing to comment on. All looks fine and tests are passing.
Attachment #8754756 - Flags: review?(hskupin) → review+
https://hg.mozilla.org/mozilla-central/rev/847f3b9f3a36
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.