Closed Bug 1274139 Opened 4 years ago Closed 4 years ago

QuickSearch: searching for text containing colons no longer works

Categories

(bugzilla.mozilla.org :: Search, defect, P1, critical)

Production
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Assigned: dylan)

Details

(Keywords: regression)

Attachments

(1 file)

https://bugzilla.mozilla.org/buglist.cgi?quicksearch=ALL%20su%3A%22ASSERTION%3A%20the%20given%20url%20scheme%20contains%20invalid%20characters%22&order=bugs.bug_id%20desc

Should find two bugs, but finds none. From the top of the page, apparently it's trying to search for:

> 'ASSERTION:' the given url scheme contains invalid characters

when it should be searching for:

> ASSERTION: the given url scheme contains invalid characters

I do this kind of search all the time, so I'm pretty sure this worked properly a few weeks ago.
Yes, I can confirm that I cannot do a search for the entire phrase "Assertion failure: ..."
Sigh. No good deed goes unpunished. Looks like a partial revert of bug 1270867 Will fix this.
Assignee: nobody → dylan
Severity: normal → critical
Priority: -- → P1
Attached patch 1274139_1.patchSplinter Review
Attachment #8754211 - Flags: review?(dkl)
Comment on attachment 8754211 [details] [diff] [review]
1274139_1.patch

Review of attachment 8754211 [details] [diff] [review]:
-----------------------------------------------------------------

r=glob
Attachment #8754211 - Flags: review?(dkl) → review+
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   3808736..aa35a9f  master -> master
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
This was pushed out to production. It was totally my fault. The next time we change quicksearch you shouldn't notice anything other than it being faster (1s queries become 0.05s queries.)
(see bug 1184823)
You need to log in before you can comment on or make changes to this bug.