Closed Bug 1274153 Opened 8 years ago Closed 8 years ago

"media-showStatistics" event is leaked to content

Categories

(Toolkit :: Video/Audio Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: xidorn, Unassigned)

References

Details

Attachments

(1 file)

Attached file testcase
Steps to reproduce:
1. open the testcase
2. right click the video
3. click "Show Statistics"

Expected result:
the statistics information is displayed directly

Actual result:
there is a prompt shows "Got media-showStatistics" because it gets that event


This event is not defined in the spec, and thus should in general not be exposed to the content. At best, it should not be exposed to <video> element. I suppose dispatching it to some internal element should be fine.
Looks like we can dispatch to chrome only from JS using the domwindowutils: https://dxr.mozilla.org/mozilla-central/source/browser/modules/PluginContent.jsm#965-971
Except the video controls are not chrome.
(In reply to Justin Dolske [:Dolske] from comment #2)
> Except the video controls are not chrome.

Ugh, good point... Also, seems I was just confused by the relationship between this and bug 1270853 - if we're removing it all anyway, then there's not much point discussing how to do it better (just need to figure out how to not break whatever test was breaking). :-)
So given bug 1270853 gets fixed, this bug no longer presents. Mark as WORKSFORME.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: