Outdated hyperlinks: SeaMonkey website offering different versions than the repositories (nightly should be 2.49a1, aurora 2.48a2) or Error "404 Not Found"

RESOLVED FIXED

Status

defect
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: RainerBielefeldNG, Assigned: ewong)

Tracking

Trunk
Unspecified
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [easyconfirm][good first bug], )

Attachments

(2 attachments)

Reporter

Description

3 years ago
Currently Project Home Page offers wrong version numbers, please compare:
              Repository Version     Home Page Version
Trunk [1]:    2.46a1                 2.43a1
Aurora [2]:   2.45a2                 2.42a2

Download areas for latest versions:
[1] <http://archive.mozilla.org/pub/seamonkey/nightly/latest-comm-central-trunk/>
[2] <http://archive.mozilla.org/pub/seamonkey/nightly/latest-comm-aurora/>
Reporter

Updated

3 years ago
Summary: SeaMonkey website reporting different versions than the repositories (nightly should be 2.46a1, aurora 2.45a1)urora → SeaMonkey website offering different versions than the repositories (nightly should be 2.46a1, aurora 2.45a2)
Reporter

Updated

3 years ago
Whiteboard: [easyconfirm][good first bug]
Reporter

Comment 1

3 years ago
Things have become worse, now we have "Error 404 Not Found "
I will try to initiate a discussion concerning a solution for the very unsatisfying situation of homepage maintenance at next Status Meeting <https://wiki.mozilla.org/SeaMonkey/StatusMeetings/2016-06-21>

NEW due to <https://blog.seamonkey-project.org/2015/11/25/my-unconfirmed-bug-reports/>
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Updated

3 years ago
Summary: SeaMonkey website offering different versions than the repositories (nightly should be 2.46a1, aurora 2.45a2) → SeaMonkey website offering different versions than the repositories (nightly should be 2.46a1, aurora 2.45a2) - or Error "404 Not Found"
Assignee

Comment 2

3 years ago
(In reply to Rainer Bielefeld from comment #0)
> Currently Project Home Page offers wrong version numbers, please compare:
>               Repository Version     Home Page Version
> Trunk [1]:    2.46a1                 2.43a1
> Aurora [2]:   2.45a2                 2.42a2
> 
> Download areas for latest versions:
> [1]
> <http://archive.mozilla.org/pub/seamonkey/nightly/latest-comm-central-trunk/>
> [2] <http://archive.mozilla.org/pub/seamonkey/nightly/latest-comm-aurora/>

Pardon for being dense...  where in the home page does it show the 2.43a1 and
2.42a2?
Assignee

Comment 3

3 years ago
(In reply to Edmund Wong (:ewong) from comment #2)
> (In reply to Rainer Bielefeld from comment #0)
> > Currently Project Home Page offers wrong version numbers, please compare:
> >               Repository Version     Home Page Version
> > Trunk [1]:    2.46a1                 2.43a1
> > Aurora [2]:   2.45a2                 2.42a2
> > 
> > Download areas for latest versions:
> > [1]
> > <http://archive.mozilla.org/pub/seamonkey/nightly/latest-comm-central-trunk/>
> > [2] <http://archive.mozilla.org/pub/seamonkey/nightly/latest-comm-aurora/>
> 
> Pardon for being dense...  where in the home page does it show the 2.43a1 and
> 2.42a2?

Nvm.. found it.  Not sure why the URL: for this bug points to the
blog.

http://www.seamonkey-project.org/dev/nightly
Reporter

Comment 4

3 years ago
I updated obsolete summary.

Indeed, URL here in Bug here is wrong, probably because of unmindful copy-paste.
Affected webpages are 
<http://www.seamonkey-project.org/dev/nightly>
<http://www.seamonkey-project.org/dev/aurora>
Hyperlinks for download are obsolete.
Summary: SeaMonkey website offering different versions than the repositories (nightly should be 2.46a1, aurora 2.45a2) - or Error "404 Not Found" → Outdated hyperlinks: SeaMonkey website offering different versions than the repositories (nightly should be 2.496a1, aurora 2.48a2) or Error "404 Not Found"
Assignee

Comment 5

3 years ago
Thanks Rainer!
Assignee

Comment 6

3 years ago
Post S3,  all our links on our website were rendered broken.

This patch fixes this; but I'm not 100% it is enough; specifically
for the entries listed in the URL. i.e. http://www.seamonkey-project.org/dev/nightly

Those are dependent on variables which, afaik, are taken from
seamonkey-project.json.   I'm wondering if updating these links
will fix it?
Attachment #8794710 - Flags: review?(jh)
Comment on attachment 8794710 [details] [diff] [review]
update links to reflect the move to S3

Review of attachment 8794710 [details] [diff] [review]:
-----------------------------------------------------------------

Haven't actually checked all the files for individual versions or outcome (i.e. whether links work) but looks OK to me. Main place is config.tmpl anyway.
Attachment #8794710 - Flags: review?(jh) → review+
Assignee

Comment 8

3 years ago
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #7)
> Comment on attachment 8794710 [details] [diff] [review]
> update links to reflect the move to S3
> 
> Review of attachment 8794710 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Haven't actually checked all the files for individual versions or outcome
> (i.e. whether links work) but looks OK to me. Main place is config.tmpl
> anyway.

Thanks!
Assignee

Comment 10

3 years ago
website content isn't updated due to bug 1305354.
Depends on: 1305354

Comment 11

3 years ago
Comment on attachment 8794710 [details] [diff] [review]
update links to reflect the move to S3

Review of attachment 8794710 [details] [diff] [review]:
-----------------------------------------------------------------

::: lib/config.tmpl
@@ -38,2 @@
>  
>  [% develbaseversion = '2.43' %]

Note that those baseversion variables should probably also be updated to the current nightly/aurora/beta/release versions, at least as much as builds are available.
Assignee

Comment 12

3 years ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #8795089 - Flags: review?(jh)
Comment on attachment 8795089 [details] [diff] [review]
update versions in config.tmpl

FYI I'm not an active reviewer anymore, so please (y'all) get this sorted.
FWIW patch looks fine.
Attachment #8795089 - Flags: review?(jh)
typo
Summary: Outdated hyperlinks: SeaMonkey website offering different versions than the repositories (nightly should be 2.496a1, aurora 2.48a2) or Error "404 Not Found" → Outdated hyperlinks: SeaMonkey website offering different versions than the repositories (nightly should be 2.49a1, aurora 2.48a2) or Error "404 Not Found"
Assignee

Updated

3 years ago
Attachment #8795089 - Flags: review?(iann_bugzilla)

Updated

3 years ago
Attachment #8795089 - Flags: review?(iann_bugzilla) → review+
Reporter

Comment 16

3 years ago
Works fine: <http://wp.me/p7kLBG-8m>. Verified / FIXED?
Reporter

Updated

3 years ago
See Also: → 1308457
Assignee

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED

Updated

Last year
Product: Websites → SeaMonkey
You need to log in before you can comment on or make changes to this bug.