bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Undefined math functions |fabsf|, |acosf|, et al in stlport headers

RESOLVED DUPLICATE of bug 1276927

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 1276927
2 years ago
5 months ago

People

(Reporter: tzimmermann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

788 bytes, text/plain
Details
m-c is 298654:5511d54a3f17. Building on B2G gives the following errors:

In file included from ../../../../../hg.mozilla.org/mozilla-central/build/stlport/stlport/stl/_cstdlib.h:169:0,
                 from ../../../../../hg.mozilla.org/mozilla-central/build/stlport/stlport/cstdlib:33,
                 from ../../../config/system_wrappers/cstdlib:3,
                 from ../../../dist/include/mozilla/mozalloc.h:21,
                 from ../../../dist/include/nscore.h:20,  
                 from ../../../dist/include/nsStringFwd.h:12,
                 from ../../../dist/include/nsAString.h:11,
                 from ../../../dist/include/nsSubstring.h:10,
                 from ../../../dist/include/nsString.h:12,
                 from ../../../dist/include/nsStringGlue.h:18,
                 from ../../../../../hg.mozilla.org/mozilla-central/intl/locale/nsIPlatformCharset.h:9,
                 from ../../../../../hg.mozilla.org/mozilla-central/intl/locale/unix/nsAndroidCharset.cpp:6:
../../../../../hg.mozilla.org/mozilla-central/build/stlport/stlport/stl/_cmath.h: In function 'float abs(float)':
../../../../../hg.mozilla.org/mozilla-central/build/stlport/stlport/stl/_cmath.h:427:1: error: '::fabsf' has not been declared
 _STLP_DEF_MATH_INLINE(abs, fabs)
 ^
../../../../../hg.mozilla.org/mozilla-central/build/stlport/stlport/stl/_cmath.h: In function 'float acos(float)':
../../../../../hg.mozilla.org/mozilla-central/build/stlport/stlport/stl/_cmath.h:432:1: error: '::acosf' has not been declared
 _STLP_DEF_MATH_INLINE(acos, acos)
 ^
../../../../../hg.mozilla.org/mozilla-central/build/stlport/stlport/stl/_cmath.h: In function 'float asin(float)':
../../../../../hg.mozilla.org/mozilla-central/build/stlport/stlport/stl/_cmath.h:433:1: error: '::asinf' has not been declared
 _STLP_DEF_MATH_INLINE(asin, asin)
 ^
../../../../../hg.mozilla.org/mozilla-central/build/stlport/stlport/stl/_cmath.h: In function 'float atan(float)':
../../../../../hg.mozilla.org/mozilla-central/build/stlport/stlport/stl/_cmath.h:434:1: error: '::atanf' has not been declared
 _STLP_DEF_MATH_INLINE(atan, atan)
 ^

This is probably fallout from recent changes in the build scripts.
Maybe it's related to bug 1273934.
See Also: → bug 1273934
if so, then we could temporarily use --with-android-cxx-stl=mozstlport ?
(In reply to Alexandre LISSY :gerard-majax from comment #2)
> if so, then we could temporarily use --with-android-cxx-stl=mozstlport ?

It's not helping but I might have a local change that helps :)
Created attachment 8757922 [details]
hack

So far it seems to be building, I am testing this.
Comment on attachment 8757922 [details]
hack

I got tricked, this is not helping anything.
Attachment #8757922 - Attachment is obsolete: true
Created attachment 8757964 [details]
new hack

this one builds a gecko, not tested running it yet.
(In reply to Alexandre LISSY :gerard-majax from comment #6)
> Created attachment 8757964 [details]
> new hack
> 
> this one builds a gecko, not tested running it yet.

Devices boots, completes FTU and can take pics with Camera app.
Thomas, are you working on this?
Flags: needinfo?(tzimmermann)
Please take it if you have a fix.
Flags: needinfo?(tzimmermann)
I'm trying to use llvm-libc++ as we have on android, but I have no idea if it's a legit fix
(In reply to Alexandre LISSY :gerard-majax from comment #10)
> I'm trying to use llvm-libc++ as we have on android, but I have no idea if
> it's a legit fix

FYI, I've been working on fixes to build B2G with Android's build scripts and NDK. I'll probably upload some patches soon.
That also fixes this problem with the math functions.
I'm closing this as duplicated as the problem has been fixed by the other bug's patch set.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1276927

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.