Table cell rendered at wrong position

RESOLVED DUPLICATE of bug 126742

Status

()

Core
Layout
P1
normal
RESOLVED DUPLICATE of bug 126742
17 years ago
17 years ago

People

(Reporter: Christian Schmidt, Assigned: karnaze (gone))

Tracking

({regression, testcase})

Trunk
Future
x86
Windows NT
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020222
BuildID:    2002022203

Under some circumstances, a table cell is drawn quite a bit below where it was
supposed to be.

Reproducible: Always

Steps to Reproduce:
1. Load test case
2. Watch the result

Actual Results:  Blue table cell is rendered so that most of it lies outside the
yellow table. The paragraph following the table in the HTML code is rendered on
top of the table contents.

Expected Results:  Blue table cell should be rendered within the yellow table.
The text following the table should not overlap with the table or the table cell.

The test case is rather fragile. If some of the parameters, e.g. height,
cellpadding etc. are changed, the page renders correctly.

The test case is a simple table that does not use CSS positioning.
(Reporter)

Comment 1

17 years ago
Created attachment 71211 [details]
Test case
(Reporter)

Updated

17 years ago
Keywords: testcase
(Reporter)

Comment 2

17 years ago
This is a recent regression. The bug was not there in build 2002021903.
Keywords: regression
worksforme, linux build 2002-02-24-06.  Windows-only?
dupe of bug 126742 ?

Comment 5

17 years ago
shows only with optimized build and does not appear with debug build, probably a
dupe.
*** Bug 127660 has been marked as a duplicate of this bug. ***
Reassigning to karnaze
Assignee: attinasi → karnaze
Priority: -- → P1
Target Milestone: --- → Future

Comment 8

17 years ago
Changing QA contact
QA Contact: petersen → amar

Comment 9

17 years ago
Testcase seems to work fine with fix to bug #126742
(I tested before the fix and layout was messy). Note
that the testcase has a style with a height value.

Reporter (or karnaze), do you agree duping this one to 126742.
(Assignee)

Comment 10

17 years ago

*** This bug has been marked as a duplicate of 126742 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.