Closed Bug 1275660 Opened 3 years ago Closed 3 years ago

developer_tools.xhtml: Dead web hyperlink for DOM Inspector tutorial

Categories

(SeaMonkey :: Help Documentation, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.46

People

(Reporter: RainerBielefeldNG, Assigned: suraj.ghimire7)

References

(Blocks 1 open bug)

Details

(Whiteboard: [easyconfirm][good first bug])

Attachments

(3 files)

1. Browser → F1
   » Help appears
2. Type search string "Development Tools" → Click hit 
  "Tools and Development"
   » Related Help appears
3. Search page for "intro"
4. Click found hyperlink "Introduction to the DOM Inspector"
   leading to <http://www.brownhen.com/DI/>
   Bug: "Oops! That page can’t be found."                           :-(

a) Website Search Tool does not find any DPM Inspector related contents
b) Alternatives on  <http://www.mozillazine.org/talkback.html?article=2649&message=5&state=reply> all have gone
c) As long as nobody knows a better tutorial that text line with 
   hyperlink should be dropped?!
d) No DUPs found with <https://bugzilla.mozilla.org/buglist.cgi?list_id=13038170&short_desc=link&query_format=advanced&short_desc_type=allwordssubstr&longdesc=help%20DOM%20Inspector%20tutorial%20link&component=Help%20Documentation&longdesc_type=allwordssubstr&product=SeaMonkey>
Hello , I want to work on this . can you tell me how to get started in this.
(In reply to Suraj Ghimire from comment #1)
> I want to work on this

Great! As a first step please try to confirm the problem by reproducing my steps 
1 ... 4.
I sent some additional hints to you by email. When the problem has been confirmed by you I will find a mentor who will help you with the next steps.
i have done steps 1 ... 4 in my computer which has Arch Linux and it giving me same problem you mentioned .
New Due to comment 3

@IanN
Can you please assist Suraj Ghimire to learn to attach patches ready for review and push?

@Suraj Ghimire
Please readd <https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/How_to_Submit_a_Patch>
You can download an en-US language pack and find the shtml source needing a fix.
Status: UNCONFIRMED → NEW
Ever confirmed: true
i have downloaded Seamonkey source code, how to find shtml source?.
(In reply to Suraj Ghimire [:ghishadow] from comment #5)
Following advice on <https://developer.mozilla.org/en-US/docs/Mozilla/Tech/Viewing_and_searching_Mozilla_source_code_online> you can search SeaMonkey Source with <https://dxr.mozilla.org/comm-central/search?>. Search for "Oeschger" will have 1 hit.
Alternatives:
Search Source using <http://mxr.mozilla.org/comm-central/search?>, will have 2 hits
Search unpacked source folders with a suitable tool for "Oeschger" will show 2 hits, one of them is "developer_tools.xhtml"

Please follow my advice in email!
please review it.
Attachment #8757700 - Flags: review?(iann_bugzilla)
Comment on attachment 8757700 [details] [diff] [review]
revision1 - Fixed Dead Link

-      <li><a href="http://www.brownhen.com/DI/">Introduction to the DOM
+      <li><a href="http://www.mozillazine.org/talkback.html?article=2649&message=5&state=reply">Introduction to the DOM
         Inspector</a> (Ian Oeschger)</li>

Thanks for the patch, but the link takes you to a page without any content. I think you should just remove the link if you can't find any pages out there with relevant content.
Attachment #8757700 - Flags: review?(iann_bugzilla)
Done removed dead link
That was quick :-)

(In reply to Stefan [:stefanh] from comment #8)
b): yes, this page does no longer contain useful links.
c): I can't tell how useful <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector/Introduction_to_DOM_Inspector> can be as a replacement for Ian Oeschger's Manual? Unfortunately there was no direct link to that page on <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector/DOM_Inspector_FAQ>, I added one directly below heading 
"How do I inspect a web site/window?"

So I agree, dropping that complete text line in SeaMonkey Help seems to be the most appropriate solution.
(In reply to Rainer Bielefeld from comment #10)

> c): I can't tell how useful
> <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector/
> Introduction_to_DOM_Inspector> can be as a replacement for Ian Oeschger's
> Manual?

Well, that looks like a possible replacement page.

> Unfortunately there was no direct link to that page on
> <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector/
> DOM_Inspector_FAQ>, I added one directly below heading 
> "How do I inspect a web site/window?"
> 
 Do you mean that you added a direct link to <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector/> somewhere?
(In reply to Stefan [:stefanh] from comment #11)
>  Do you mean that you added a direct link to
> <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector/>
And that should of course be <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector/Introduction_to_DOM_Inspector>
Assignee: nobody → suraj.ghimire7
Status: NEW → ASSIGNED
Aha, now I understand what you ment. If you did that devmo change just for SeaMonkey, I think you should revert it. You don't need to add that link on devmo since we can have it in the help file instead. Also, on devmo, you are supposed to get to the FAQ and the Introduction pages from the main page so it will probably be a bit odd to have a link to the introduction page in the FAQ page.
Flags: needinfo?(RainerBielefeldNG)
Comment on attachment 8757704 [details] [diff] [review]
revision2- Dropped Dead Link

Sorry Suraj, we'll have to do another round here. Can you please replace the dead link with a link to https://developer.mozilla.org/en/DOM_Inspector/Introduction_to_DOM_Inspector instead.

Also, there's a link below that was commented out in 2006. I think 10 years is enought, so please remove it :-)

I can do the review, just use stefanh@inbox.com in the requestee field.
(In reply to Stefan [:stefanh] from comment #13)
> Aha, now I understand what you ment. 
On devmo on "DOM Inspector FAQ" <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector/DOM_Inspector_FAQ> I added the link to "Introduction to DOM Inspector" directly below Heading "How do I inspect a web site/window?"

In SM Help developer_tools.xhtml we already have the link to "DOM Inspector FAQ" <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector/DOM_Inspector_FAQ>, and I think it is better to have links between DOM related articles on devmo than to have a list with devmo links in SeaMonkey Help.

I prefer to keep the solution intended with patch revision2
Flags: needinfo?(RainerBielefeldNG)
OK, I agree that it's better to have one link to devmo. But then it's much better to link to the main page: https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector.

So lets remove the dead link (and the stuff that was commented out in 2006), and replace the link to to http://www.mozilla.org/projects/inspector/faq.html with a link to https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector and call it "DOM Inspector" and refer to developer.mozilla.org ("DOM Inspector FAQ</a> (mozilla.org)</li>" becomes DOM Inspector</a> (developer.mozilla.org)</li>)".
(In reply to Stefan [:stefanh] from comment #16)
> OK, I agree that it's better to have one link to devmo. But then it's much
> better to link to the main page:
> https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector.

You are right, that's optimal, and there we already have the link to the basic instruction. I will revert my change at "Faq"

@Suraj Ghimire:
Thats's fate: 10 years nobody cared, and no you become victim of expert's discussion what solution might be the best. I am pretty sure that suggestion from comment 16 will be the final one.

What means (details):
- Changes in your "revision2- Dropped Dead Link" will stay
- Additionally in revision3
 - Change text 
    old: "DOM Inspector FAQ (mozilla.org)"
    new: "DOM Inspector Documentation (developer.mozilla.org)"
         Link changes to 
         <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector>

@Stefan:
Do you agree?
(In reply to Rainer Bielefeld from comment #17)
    new: "DOM Inspector Documentation (developer.mozilla.org)"
         Link changes to 
         <https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector>

Just call it "DOM Inspector (developer.mozilla.org)" since that's what the page heading says. For the rest, se my previous comment.
Done , removed commented lines and added new link
Attachment #8757741 - Flags: review?(stefanh)
Comment on attachment 8757741 [details] [diff] [review]
revision3 - Added new link , removed coomented lines

Thanks!

-      -->
+      <li><a href="https://developer.mozilla.org/en-US/docs/Tools/Add-ons/DOM_Inspector">DOM Inspector</a>(developer.mozilla.org)</li>

This line is too long (we try the best we can to keep lines at max 80 chars), but I'll fix that. I also changed the commit message a bit.
Attachment #8757741 - Flags: review?(stefanh) → review+
http://hg.mozilla.org/comm-central/rev/cf279cc83506
Target Milestone: --- → seamonkey2.46
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
fix VERIFIED with  English SeaMonkey 2.47a1  (NT 6.1; Win64; x64; rv:50.0)  Gecko/20100101 Firefox/50.0 Build 20160628114904  (Default Classic Theme)  on German WIN7 64bit
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.