Turn off e10s tests for OS X 10.6 in automation

RESOLVED FIXED

Status

defect
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: Felipe, Assigned: RyanVM)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(e10s?)

Details

Attachments

(1 attachment, 1 obsolete attachment)

e10s will be blocked for OS X 10.6 - 10.8 on Firefox 48, so we need to turn off the tests to keep the tree happy.
No point in leaving them running anywhere. 10.6 is never going to see e10s support in any shipping product anyway.
Component: General → General Automation
Product: Testing → Release Engineering
QA Contact: catlee
Summary: Turn off e10s tests for OS X 10.6 - 10.8 on Firefox 48 → Turn off e10s tests for OS X 10.6 in automation
Version: 48 Branch → ---
That was easier than I expected it to be.

Builders removed
- Rev4 MacOSX Snow Leopard 10.6 mozilla-aurora opt test mochitest-e10s-browser-chrome-1
- Rev4 MacOSX Snow Leopard 10.6 mozilla-aurora opt test mochitest-e10s-browser-chrome-2
- Rev4 MacOSX Snow Leopard 10.6 mozilla-aurora opt test mochitest-e10s-browser-chrome-3
- Rev4 MacOSX Snow Leopard 10.6 mozilla-beta opt test mochitest-e10s-browser-chrome-1
- Rev4 MacOSX Snow Leopard 10.6 mozilla-beta opt test mochitest-e10s-browser-chrome-2
- Rev4 MacOSX Snow Leopard 10.6 mozilla-beta opt test mochitest-e10s-browser-chrome-3
- Rev4 MacOSX Snow Leopard 10.6 mozilla-release opt test mochitest-e10s-browser-chrome-1
- Rev4 MacOSX Snow Leopard 10.6 mozilla-release opt test mochitest-e10s-browser-chrome-2
- Rev4 MacOSX Snow Leopard 10.6 mozilla-release opt test mochitest-e10s-browser-chrome-3
- Rev4 MacOSX Snow Leopard 10.6 try opt test mochitest-e10s-browser-chrome-1
- Rev4 MacOSX Snow Leopard 10.6 try opt test mochitest-e10s-browser-chrome-2
- Rev4 MacOSX Snow Leopard 10.6 try opt test mochitest-e10s-browser-chrome-3
- Rev4 MacOSX Snow Leopard 10.6 try opt test mochitest-e10s-browser-chrome-4
- Rev4 MacOSX Snow Leopard 10.6 try opt test mochitest-e10s-browser-chrome-5
- Rev4 MacOSX Snow Leopard 10.6 try opt test mochitest-e10s-browser-chrome-6
- Rev4 MacOSX Snow Leopard 10.6 try opt test mochitest-e10s-browser-chrome-7
Attachment #8756591 - Flags: review?(rail)
Attachment #8756591 - Flags: review?(rail) → review?(jlund)
Comment on attachment 8756591 [details] [diff] [review]
turn of e10s tests on OSX 10.6

Review of attachment 8756591 [details] [diff] [review]:
-----------------------------------------------------------------

I'm assuming we don't want to run any e10s on 10.6 in _any_ branch and not just phase it out on trunk?

quick scanning *_E10S lines in mozilla-tests/config.py suggests that we this block doesn't explicitly block snowleopard from clipboard e10s tests: http://hg.mozilla.org/build/buildbot-configs/file/d2ba520c6440/mozilla-tests/config.py#l3318

the other loops in that file either block 10.6 or provide an explicit list that doesn't include 10.6. at least at glance :)

::: mozilla-tests/config.py
@@ +3113,2 @@
>  #   Enable e10s web-platform-tests
>  # Bug 1200437 - Use 7 chunks for m-e10-bc on branches > trunk, excluding twigs, 3 chunks elsewhere

side note: this comment seems inaccurate since we are not locking to trunk anymore and instead using static version 46.0
Attachment #8756591 - Flags: review?(jlund) → review+
(In reply to Jordan Lund (:jlund) from comment #3)
> I'm assuming we don't want to run any e10s on 10.6 in _any_ branch and not
> just phase it out on trunk?

Correct, bug 1275040 is going to be explicitly blocking e10s from being enabled on 10.6-10.8 and will be getting uplifted to Gecko 48, which is the first release we're targeting for e10s GA.

> quick scanning *_E10S lines in mozilla-tests/config.py suggests that we this
> block doesn't explicitly block snowleopard from clipboard e10s tests:
> http://hg.mozilla.org/build/buildbot-configs/file/d2ba520c6440/mozilla-tests/
> config.py#l3318

Done. This only affected Try since Gecko 49+ branches already have 10.6 tests disabled across the board. I also double-checked allthethings.json to verify that there weren't any other Try-specific 10.6 e10s tests hanging around and everything checked out. Note that I also ended up disabling the non-e10s versions of the clipboard/gpu jobs for Try, but that's OK since they're only scheduled on 49+ where 10.6 tests are disabled anyway. If anything, doing so removes what would inevitably end up being a source of confusion for anyone pushing Gecko <49 to Try and getting busted results.

> ::: mozilla-tests/config.py
> @@ +3113,2 @@
> >  #   Enable e10s web-platform-tests
> >  # Bug 1200437 - Use 7 chunks for m-e10-bc on branches > trunk, excluding twigs, 3 chunks elsewhere
> 
> side note: this comment seems inaccurate since we are not locking to trunk
> anymore and instead using static version 46.0

I think that comment is still correct. The trunk part of it applies more to lines 3126 and 3146 IIUC.

https://hg.mozilla.org/build/buildbot-configs/rev/f5fa52ba7df1
Attachment #8756591 - Attachment is obsolete: true
Attachment #8756656 - Flags: review+
Attachment #8756656 - Flags: checked-in+
Confirmed that OSX 10.6 e10s tests are no longer being scheduled on Aurora or Beta.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.